Bug 166049 - GF v3 prelude should be the default server
GF v3 prelude should be the default server
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Rails
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
Depends on: 166146
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 16:57 UTC by Petr Jiricka
Modified: 2009-06-15 10:11 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-05-26 16:57:52 UTC
Currently the GF v3 Gem is the default server when creating a Rails app. Instead, v3 Prelude should be the default server.
Comment 1 Petr Jiricka 2009-05-27 16:53:37 UTC
With the updated v3 Prelude, debugging does not work, per e-mail by Peter Williams: "Debugging doesn't work -- I need to
file an issue, been investigating but still unclear why.  Could be rdebug backend issue or JRuby issue.  Could also be
V3.  Appears to be having difficulty matching thread id's."

This needs to be resolved first before v3 Prelude is made the default.
Comment 2 Marian Mirilovic 2009-06-01 11:21:10 UTC
> e-mail by Peter Williams: "Debugging doesn't work -- I need to
> file an issue, been investigating but still unclear why.  Could be rdebug backend issue or JRuby issue.  Could also be
> V3.  Appears to be having difficulty matching thread id's."

Petr, do you think it will be solved before RC2/FCS ?
Comment 3 _ pcw 2009-06-02 05:29:07 UTC
The issue is likely with the backend, either JRuby or GlassFish.  I don't know at this point when I will know what is
wrong.  Too busy with JavaOne prep.  I may be able to look at it tomorrow (tuesday my time).
Comment 4 _ pcw 2009-06-11 19:39:49 UTC
Debugging Ruby/Rails is working now for NB 6.7 RC3 (just integrated - may need to wait for build) and V3 Prelude B28E.
Comment 5 Erno Mononen 2009-06-12 08:44:05 UTC
Fixed in http://hg.netbeans.org/ruby-main/rev/1171de4336a4, QE please verify.
Comment 6 Martin Schovanek 2009-06-12 12:36:26 UTC
Verified by QE in continuous build.
Comment 7 Marian Mirilovic 2009-06-12 15:21:16 UTC
erno, 
could you please proceed with integration into release67 before Sunday 22.00 CEST ? Thanks in advance.
Comment 8 Erno Mononen 2009-06-12 15:33:50 UTC
OK, I've transplanted the fix in http://hg.netbeans.org/release67/rev/5c2db825f559.
Comment 9 Quality Engineering 2009-06-12 19:59:31 UTC
Integrated into 'main-golden', will be available in build *200906121401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1171de4336a4
User: Erno Mononen <emononen@netbeans.org>
Log: #166049: GF v3 prelude should be the default server
Comment 10 Martin Schovanek 2009-06-15 10:11:29 UTC
Verified in 6.7RC3 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo