Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166029 - NullPointerException at org.netbeans.modules.parsing.impl.indexing.FileObjectIndexable.getURL
NullPointerException at org.netbeans.modules.parsing.impl.indexing.FileObject...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 67patch1-verified
:
: 167296 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 13:18 UTC by Oleg Khokhlov
Modified: 2009-09-01 04:22 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.45 KB, text/plain)
2009-05-26 13:19 UTC, Oleg Khokhlov
Details
stacktrace (1.45 KB, text/plain)
2009-05-28 12:05 UTC, soldatov
Details
stacktrace (1.45 KB, text/plain)
2009-05-28 17:55 UTC, Alexey Vladykin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Khokhlov 2009-05-26 13:18:36 UTC
Build: NetBeans IDE 6.7 RC1 (Build 200905232021)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
GUEST: Create C/C++ project
Rename C/C++  project
Delete C/C++ project

ovk: create/rename/delete c++ application



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.parsing.impl.indexing.FileObjectIndexable.getURL(FileObjectIndexable.java:97)
        at org.netbeans.modules.parsing.spi.indexing.Indexable.getURL(Indexable.java:93)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.indexEmbedding(RepositoryUpdater.java:1167)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:1084)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$FileListWork.getDone(RepositoryUpdater.java:1372)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:1259)
Comment 1 Oleg Khokhlov 2009-05-26 13:19:02 UTC
Created attachment 82796 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-05-27 09:11:29 UTC
I'll fix that.
Comment 3 soldatov 2009-05-28 12:05:46 UTC
Build: NetBeans IDE 6.7 RC1 (Build 200905280001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
I deleted C/C++ sample

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.parsing.impl.indexing.FileObjectIndexable.getURL(FileObjectIndexable.java:97)
        at org.netbeans.modules.parsing.spi.indexing.Indexable.getURL(Indexable.java:93)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.indexEmbedding(RepositoryUpdater.java:1167)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:1084)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$FileListWork.getDone(RepositoryUpdater.java:1372)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:1259)
Comment 4 soldatov 2009-05-28 12:05:55 UTC
Created attachment 82903 [details]
stacktrace
Comment 5 Alexey Vladykin 2009-05-28 17:55:16 UTC
Build: NetBeans IDE Dev (Build 090527)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-gentoo-r5, amd64

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.parsing.impl.indexing.FileObjectIndexable.getURL(FileObjectIndexable.java:97)
        at org.netbeans.modules.parsing.spi.indexing.Indexable.getURL(Indexable.java:93)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.indexEmbedding(RepositoryUpdater.java:1169)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:1086)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$FileListWork.getDone(RepositoryUpdater.java:1374)
        at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:1261)
Comment 6 Alexey Vladykin 2009-05-28 17:55:25 UTC
Created attachment 82933 [details]
stacktrace
Comment 7 Vitezslav Stejskal 2009-05-28 18:05:19 UTC
http://hg.netbeans.org/jet-main/rev/217ad8df9992
Comment 8 Quality Engineering 2009-05-29 08:24:27 UTC
Integrated into 'main-golden', will be available in build *200905290201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/217ad8df9992
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #166029: ignore deleted files
Comment 9 Oleg Khokhlov 2009-05-29 13:32:05 UTC
v. in 20090529
Comment 10 soldatov 2009-06-05 13:27:39 UTC
Can you add this fix into patch to NB6.7?
Comment 11 Vitezslav Stejskal 2009-06-18 14:05:15 UTC
*** Issue 167296 has been marked as a duplicate of this issue. ***
Comment 12 Jiri Prox 2009-06-24 15:51:12 UTC
justification of patch candidate: very easy reproducible, probably would affect lot of users
Comment 13 pgebauer 2009-07-01 10:53:52 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/b607cdf801bc
Comment 14 Oleg Khokhlov 2009-07-15 12:20:48 UTC
v. in 6.7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo