Bug 166020 - Not all documents GCed
Not all documents GCed
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@debugger
http://ruhudson4qe.russia.sun.com/vie...
perfleak
: PERFORMANCE, REGRESSION, TEST
: 166975 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 11:04 UTC by Ivan Sidorkin
Modified: 2009-07-09 15:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-05-26 11:04:03 UTC
reproduced since NetBeans Platform Dev (Build 200905220201)


Are all documents GCed? TextDocument: private static org.netbeans.modules.debugger.jpda.ui.CodeEvaluator
org.netbeans.modules.debugger.jpda.ui.CodeEvaluator.defaultInstance->
org.netbeans.modules.debugger.jpda.ui.CodeEvaluator@13ac3a5-codePane-> javax.swing.JEditorPane@95ea35-model->
org.netbeans.modules.editor.NbEditorDocument@406986-documentProperties->
org.netbeans.modules.editor.NbEditorDocument$2@3c7627-table-> [Ljava.util.Hashtable$Entry;@17d8259-[26]->
java.util.Hashtable$Entry@87f84f-value-> org.netbeans.api.lexer.InputAttributes@1ff1a51-lp2attrs->
java.util.HashMap@42771f-table-> [Ljava.util.HashMap$Entry;@757791-[13]-> java.util.HashMap$Entry@1fda0d4-value->
org.netbeans.api.lexer.InputAttributes$LPAttrs@f86099-globals-> java.util.HashMap@1eca43c-table->
[Ljava.util.HashMap$Entry;@195d3b4-[4]-> java.util.HashMap$Entry@1414eee-value->
org.netbeans.modules.editor.NbEditorDocument@ee09f8
Comment 1 Marian Mirilovic 2009-05-26 11:15:10 UTC
needs to be evaluated for NB 6.7
Comment 2 Martin Entlicher 2009-05-26 13:14:53 UTC
I guess this is P2 only because it breaks tests. There's just one Evaluator's document held on a static reference. Can
be solved by a WeakReference. The memory consumption is small and it does not grow. The impact on memory management is
therefore small.
Comment 3 Ivan Sidorkin 2009-05-26 13:36:43 UTC
little bit different in trunk

Are all documents GCed? TextDocument: private static
org.netbeans.modules.debugger.ui.actions.AddBreakpointAction$AddBreakpointDialogManager
org.netbeans.modules.debugger.ui.actions.AddBreakpointAction.abdm->
org.netbeans.modules.debugger.ui.actions.AddBreakpointAction$AddBreakpointDialogManager@a24ac8-controller->
org.netbeans.modules.debugger.jpda.ui.breakpoints.ClassBreakpointPanel@18d382-conditionsPanel->
org.netbeans.modules.debugger.jpda.ui.breakpoints.ConditionsPanel@72bd07-tfCondition->
javax.swing.JEditorPane@18aa724-model-> org.netbeans.modules.editor.NbEditorDocument@13d55dd-documentProperties->
org.netbeans.modules.editor.NbEditorDocument$2@52485c-table-> [Ljava.util.Hashtable$Entry;@67c998-[13]->
java.util.Hashtable$Entry@194442c-value-> org.netbeans.api.lexer.InputAttributes@14ee0ae-lp2attrs->
java.util.HashMap@1929e5b-table-> [Ljava.util.HashMap$Entry;@13481c-[1]-> java.util.HashMap$Entry@3cf429-value->
org.netbeans.api.lexer.InputAttributes$LPAttrs@5c2346-globals-> java.util.HashMap@190f8ce-table->
[Ljava.util.HashMap$Entry;@1456df4-[4]-> java.util.HashMap$Entry@ff3e31-value->
org.netbeans.modules.editor.NbEditorDocument@fcc720
Comment 4 Martin Entlicher 2009-05-26 13:55:15 UTC
This code is there for ages (5 years).
And it was found only because we changed some JTextFields to JEditorPanes. Nothing changed in the logic and I do not see
any reason for fixing this now into 6.7.
Comment 5 Tomas Pavek 2009-05-26 17:00:57 UTC
Does not ahve to be fixed in 6.7, just evaluated. Does not seem to be leaking of user's documents (i.e. editor 
documents of sources). Some debugger UI (breakpoint dialog, evaluator) could be released when not used...
Comment 6 Martin Entlicher 2009-06-12 10:36:17 UTC
*** Issue 166975 has been marked as a duplicate of this issue. ***
Comment 7 Martin Entlicher 2009-06-12 10:37:30 UTC
*** Issue 166975 has been marked as a duplicate of this issue. ***
Comment 8 Daniel Prusa 2009-06-18 14:39:40 UTC
Fixed.
http://hg.netbeans.org/main/rev/5acffbc81429
Comment 9 Quality Engineering 2009-06-19 20:23:06 UTC
Integrated into 'main-golden', will be available in build *200906191401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5acffbc81429
User: Daniel Prusa <dprusa@netbeans.org>
Log: #166020: Not all documents GCed
Comment 10 Ivan Sidorkin 2009-07-09 15:31:30 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo