Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166016 - Watches don't refresh when moving current debugging frame
Watches don't refresh when moving current debugging frame
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@debugger
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 10:46 UTC by Vojtech Sigler
Modified: 2009-07-23 14:04 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (55.74 KB, image/png)
2009-05-26 10:47 UTC, Vojtech Sigler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Sigler 2009-05-26 10:46:48 UTC
Product Version: NetBeans IDE 6.7 RC1 (Build 200905232021)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)

When moving the current debugging frame using the Call Stack view, watches don't refresh.

Steps to reproduce:

1) Open project MemoryView (http://qa.netbeans.org/modules/debugger/promo-h/MemoryView.zip), file MemoryView.java
2) Add breakpoing to line 101
3) Debug Project
4) Open Watches view and add a watch 'free'
5) in Call Stack view select second line and invoke Make Current from the popup menu (caret moves to line 58 -
updateStatus())
6) change back to Watches view, the watch now shows a number even though the variable is not valid (known) in current scope
7) if you create a new watch of the same variable, it correctly shows '"free" is not a known variable in the current
context.'
Comment 1 Vojtech Sigler 2009-05-26 10:47:45 UTC
Created attachment 82783 [details]
Screenshot
Comment 2 Martin Entlicher 2009-05-27 09:35:48 UTC
Reproduced, watches are not refreshed when current stack frame is changed.
Comment 3 Vojtech Sigler 2009-06-02 16:26:36 UTC
In the view of other possibly less important things that are getting fixed into RC2, I'm wondering if this shouldn't be
reevaluated to 6.7 and fixed before FCS.

Would the fix be dangerous/complicated?

Filip, Marian, what do you think?
Comment 4 Filip Zamboj 2009-06-02 16:42:54 UTC
this depends on martin. If he consider this as a safe fix than it would be great. 
Comment 5 Martin Entlicher 2009-06-02 17:13:16 UTC
Curiously, I'm not able to reproduce this issue in my dev build. Can not this be caused by issue #165934?
Can you please try to reproduce this in latest 6.7 build and latest trunk build? Thanks.
Comment 6 Filip Zamboj 2009-06-02 17:52:26 UTC
It's reproducible in 

trunk 
Product Version: NetBeans IDE Dev (Build 090602)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

and in RC2 
Product Version: NetBeans IDE 6.7 RC2 (Build 200906020001)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

watches won't refresh after you change current stack frame nor in watches view nor in variables view
Comment 7 Filip Zamboj 2009-06-02 18:05:30 UTC
i actually followed steps from vsigler
Comment 8 Vojtech Sigler 2009-06-03 09:11:46 UTC
I also reproduced it in both RC2 and latest trunk build.

According to Marian, it would be nice to have in FCS, but it needs to be well tested in trunk. => candidate for 6.7 Patch 1.

Raising to P2.
Comment 9 Vojtech Sigler 2009-06-09 09:12:11 UTC
Incorrect info in wiki:

67fixes1-candidate -> 67patch-candidate
Comment 10 Daniel Prusa 2009-06-24 23:32:07 UTC
Fixed in trunk.
http://hg.netbeans.org/main/rev/b920e484dfba
Comment 11 Quality Engineering 2009-06-25 20:27:37 UTC
Integrated into 'main-golden', will be available in build *200906251410* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b920e484dfba
User: Daniel Prusa <dprusa@netbeans.org>
Log: #166016: Watches don't refresh when moving current debugging frame
Comment 12 Vojtech Sigler 2009-07-02 13:18:41 UTC
Verified in trunk build (200907020200).
Comment 13 pgebauer 2009-07-03 12:36:01 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/f2ef1309348b
Comment 14 Martin Entlicher 2009-07-22 15:48:03 UTC
This fix might work for this purpose, but has caused a regression - issue #168890.

This fixed should be REMOVED from release67_fixes, or fix of issue #168890 needs to be included as well!
Comment 15 Martin Entlicher 2009-07-22 16:14:43 UTC
The fix was corrected in http://hg.netbeans.org/main/rev/c7fa3e8932d7 therefore this can be closed back as fixed.
Comment 16 Quality Engineering 2009-07-23 07:52:22 UTC
Integrated into 'main-golden', will be available in build *200907230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c7fa3e8932d7
User: mentlicher@netbeans.org
Log: #168890 - Correct the fix of issue #166016 - assure that PROP_STATE property is processed.
Comment 17 Vojtech Sigler 2009-07-23 14:04:55 UTC
Verified in Dev (Build 200907230201) as well as in 6.7.1 (Build 200907230233)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo