Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166002 - [67cat] UnsupportedOperationException at com.sun.tools.javac.jvm.ClassReader$SourceFileObject.getCharContent
[67cat] UnsupportedOperationException at com.sun.tools.javac.jvm.ClassReader$...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 07:01 UTC by ulfzibis
Modified: 2010-02-11 08:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.35 KB, text/plain)
2009-05-26 07:01 UTC, ulfzibis
Details
stacktrace (4.86 KB, text/plain)
2010-02-11 08:52 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2009-05-26 07:01:20 UTC
Build: NetBeans IDE Dev (Build 200905160201)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
GUEST: Loading AWT & Java 2d Open JDK



Stacktrace: 
java.lang.UnsupportedOperationException
        at com.sun.tools.javac.jvm.ClassReader$SourceFileObject.getCharContent(ClassReader.java:2334)
        at com.sun.tools.javac.jvm.ClassReader$SourceFileObject.getCharContent(ClassReader.java:2290)
        at com.sun.tools.javac.util.DiagnosticSource.initBuf(DiagnosticSource.java:179)
        at com.sun.tools.javac.util.DiagnosticSource.findLine(DiagnosticSource.java:147)
        at com.sun.tools.javac.util.DiagnosticSource.getLineNumber(DiagnosticSource.java:71)
        at com.sun.tools.javac.util.JCDiagnostic.<init>(JCDiagnostic.java:295)
Comment 1 ulfzibis 2009-05-26 07:01:27 UTC
Created attachment 82770 [details]
stacktrace
Comment 2 Dusan Balek 2009-06-30 11:06:32 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/d259954a1709

changeset 2013118d09cb in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=2013118d09cb
Comment 3 Quality Engineering 2009-07-01 05:30:39 UTC
Integrated into 'main-golden', will be available in build *200907010200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d259954a1709
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #166002: UnsupportedOperationException at com.sun.tools.javac.jvm.ClassReader$SourceFileObject.getCharContent - fixed.
Comment 4 Petr Blaha 2009-07-02 13:34:04 UTC
Can't reproduce in the latest trunk build.
Comment 5 pgebauer 2009-07-08 20:09:22 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/c4e69e16a962
Comment 6 pgebauer 2009-07-09 09:18:33 UTC
The fix above is encapsulated in javac-impl-nb-7.0-b07.jar together with a few other bugfixes those are not intended for 67patch1 and they cause 
following compiler error:

java.source/src/org/netbeans/modules/java/source/TreeLoader.java:179: cannot find symbol
symbol  : constructor CouplingAbort(javax.tools.JavaFileObject,com.sun.source.tree.Tree)
location: class com.sun.tools.javac.util.CouplingAbort
          throw new CouplingAbort(clazz.classfile, t);


As far as I can be concrete, changes with following commit messages:
- Do not store end positions on background scan.
- Improved logging of coupling errors.
from the list at http://hg.netbeans.org/main-golden/log/d259954a1709/libs.javacimpl/external/binaries-list caused the problem.

The fix has been rolled back from the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/
Comment 7 pgebauer 2009-07-09 09:19:39 UTC
The fix above is encapsulated in javac-impl-nb-7.0-b07.jar together with a few other bugfixes those are not intended for 67patch1 and they cause 
following compiler error:

java.source/src/org/netbeans/modules/java/source/TreeLoader.java:179: cannot find symbol
symbol  : constructor CouplingAbort(javax.tools.JavaFileObject,com.sun.source.tree.Tree)
location: class com.sun.tools.javac.util.CouplingAbort
          throw new CouplingAbort(clazz.classfile, t);


As far as I can be concrete, changes with following commit messages:
- Do not store end positions on background scan.
- Improved logging of coupling errors.
from the list at http://hg.netbeans.org/main-golden/log/d259954a1709/libs.javacimpl/external/binaries-list caused the problem.

The fix has been rolled back from the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/7b1ecbc40dab
Comment 8 Dusan Balek 2009-07-13 16:21:11 UTC
The fix has been ported into the release67_fixes repository.

http://hg.netbeans.org/release67_fixes/rev/3bda960ef4e2
http://hg.netbeans.org/release67_fixes/rev/12e73c111e83
Comment 9 Jiri Prox 2009-07-16 15:30:35 UTC
v in 6.7.1
Comment 10 Egor Ushakov 2010-02-11 08:52:45 UTC
Created attachment 94089 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo