Bug 165971 - discoverability of intelligent issue search should be improved
discoverability of intelligent issue search should be improved
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Bugzilla
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@connecteddeveloper
: PLAN
Depends on:
Blocks: 165924
  Show dependency treegraph
 
Reported: 2009-05-25 15:46 UTC by Ondrej Langr
Modified: 2009-08-25 02:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
search discoverability improvement (97.76 KB, image/png)
2009-06-10 11:32 UTC, Ondrej Langr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Langr 2009-05-25 15:46:51 UTC
Field for searching issues was generally appraised by participants in the usability study, but it's function was
typically not recognized at first (only after participants started typing into the field).

We should probably add better indication that issues can actually be identified by "choosing", not just by typing. 

Intended for the version after 6.7.
Comment 1 Ondrej Langr 2009-06-09 21:10:02 UTC
Attached is a sketch of UI solving this problem.

Clicking the "combo" sign on the right would drop down a standard list with issues this field is using. The list would
contain 5 most recently opened issues. Starting to type would behave as this fields behaves now .. would search all
cached queries.
Comment 2 Ondrej Langr 2009-06-10 11:32:31 UTC
Created attachment 83394 [details]
search discoverability improvement
Comment 3 Ondrej Langr 2009-06-10 12:08:09 UTC
Please use the word "summary" instead of "description"
Comment 4 Ondrej Langr 2009-07-24 14:14:07 UTC
UI solving the problem is done, reassigning to bugtracking for implementation. 
Comment 5 Tomas Stupka 2009-08-19 16:50:22 UTC
fixed

changeset   : 141521:eff575e488d2
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Wed Aug 19 16:37:51 CEST 2009
Comment 6 Quality Engineering 2009-08-21 06:16:11 UTC
Integrated into 'main-golden', will be available in build *200908210201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/eff575e488d2
User: Tomas Stupka <tstupka@netbeans.org>
Log: #165971 - discoverability of intelligent issue search should be improved
Comment 7 Quality Engineering 2009-08-25 02:41:25 UTC
Integrated into 'main-golden', will be available in build *200908242212* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a1bbded37d53
User: Tomas Stupka <tstupka@netbeans.org>
Log: #165971 - discoverability of intelligent issue search should be improved
fixing label wording


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo