Bug 165952 - NullPointerException at org.openide.filesystems.FileUtil.toFile
NullPointerException at org.openide.filesystems.FileUtil.toFile
Status: VERIFIED DUPLICATE of bug 165950
Product: javame
Classification: Unclassified
Component: CDC pack
6.x
All All
: P1 (vote)
: TBD
Assigned To: Petr Suchomel
issues@mobility
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 14:36 UTC by bcygan
Modified: 2009-05-29 13:13 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.09 KB, text/plain)
2009-05-25 14:36 UTC, bcygan
Details
stacktrace (1.97 KB, text/plain)
2009-05-26 10:52 UTC, Peter Nabbefeld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bcygan 2009-05-25 14:36:04 UTC
Build: NetBeans IDE Dev (Build 200905250001)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows Vista, 6.0, amd64

User Comments:
bcygan: opening project

bcygan: opening project



Stacktrace: 
java.lang.NullPointerException
        at org.openide.filesystems.FileUtil.toFile(FileUtil.java:828)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.resolveRelativePathToFileObject(CDCPlatform.java:522)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.resolveRelativePathToFileObjects(CDCPlatform.java:510)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.getAllLibraries(CDCPlatform.java:491)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.getBootstrapLibraries(CDCPlatform.java:304)
        at org.netbeans.modules.java.platform.queries.PlatformSourceForBinaryQuery.findSourceRoots2(PlatformSourceForBinaryQuery.java:92)
Comment 1 bcygan 2009-05-25 14:36:09 UTC
Created attachment 82739 [details]
stacktrace
Comment 2 Peter Nabbefeld 2009-05-26 10:52:36 UTC
Build: NetBeans IDE Dev (Build 200905260001)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 
I'm not using j2me. Seems, either the j2se implementation uses sth. of j2me, or project type detection might be broken. However, I've got many FIleUtil related exceptions, and these exceptions in turn seem to be related to URI parsing, probably (again) because of spaces in file paths.

Stacktrace: 
java.lang.NullPointerException
        at org.openide.filesystems.FileUtil.toFile(FileUtil.java:828)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.resolveRelativePathToFileObject(CDCPlatform.java:522)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.resolveRelativePathToFileObjects(CDCPlatform.java:510)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.getAllLibraries(CDCPlatform.java:491)
        at org.netbeans.modules.j2me.cdc.platform.CDCPlatform.getBootstrapLibraries(CDCPlatform.java:304)
        at org.netbeans.modules.java.platform.queries.PlatformSourceForBinaryQuery.findSourceRoots2(PlatformSourceForBinaryQuery.java:92)
Comment 3 Peter Nabbefeld 2009-05-26 10:52:57 UTC
Created attachment 82784 [details]
stacktrace
Comment 4 Peter Nabbefeld 2009-05-26 11:02:57 UTC
With latest daily build, couldn't do anything, as every 1-2 seconds an exception occured, making working impossible.
Thus setting priority to P2.
Comment 5 Antonin Nebuzelsky 2009-05-28 15:01:10 UTC
Reassigned to mobility/CDC. FileUtil.toFile is obviously passed a Null parameter...
Comment 6 Marian Mirilovic 2009-05-28 15:38:57 UTC
Psuchomel, please evaluate ASAP. 

.... I checked exceptions and itlooks like all are from trunk .. and all on Win
Comment 7 Petr Suchomel 2009-05-28 15:54:48 UTC
I suspect this is in short connection with 165950 which has been fixed. Can user verify with latest build?
Comment 8 Marian Mirilovic 2009-05-28 16:23:40 UTC
psuchomel, 
issue 165950 was fixed in trunk on May/27 and reports in this issue comes from builds before and after this fix ;(
Comment 9 bcygan 2009-05-28 16:37:16 UTC
I checked with 200905280201, the bug is still there. 
Comment 10 Petr Suchomel 2009-05-28 17:03:24 UTC
It seems I'll be able to fix this one today - wrong assumption, give me a little time to find.
Comment 11 Petr Suchomel 2009-05-28 18:44:42 UTC

*** This issue has been marked as a duplicate of 165950 ***
Comment 12 Andrei Chistiakov 2009-05-29 13:13:21 UTC
Fix is verified with NetBeans IDE Dev (Build 200905290201)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo