Bug 165934 - Wrong column order in debugger views
Wrong column order in debugger views
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
: REGRESSION
: 165821 165910 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 11:12 UTC by Alexander Pepin
Modified: 2009-05-27 10:58 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Dumps showing what events the set of a column name cause. (37.93 KB, text/plain)
2009-05-26 09:50 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2009-05-25 11:12:46 UTC
Now (in RC1 candidate build) in all debugger views (Watches, Variables, Call Stack, etc.) all column are enabled and
have wrong order. This make a mess in all debugging views especially taking into account issue #165905
Comment 1 Martin Entlicher 2009-05-25 13:43:48 UTC
Reproduced, it's a regression. It's certainly not desired, should be a showstopper for RC1 IMHO.
Comment 2 Alexander Pepin 2009-05-25 13:52:28 UTC
follow the showstopper process
Comment 3 Martin Entlicher 2009-05-26 09:38:28 UTC
The regression is caused by changeset:   133054:11d25ef69401
http://hg.netbeans.org/main/rev/11d25ef69401

I do not think this is a defect in debugger.
The call ((NodeOutlineModel) model).setNodesColumnLabel(manager.getRootContext().getDisplayName());
as a result rebuilds twice the whole table! This is really not expected. The columns which I've set are removed and
*all* columns (regardless of which I've set as visible) are added to the table. This is too much work for a new label.

Comment 4 Martin Entlicher 2009-05-26 09:50:20 UTC
Created attachment 82781 [details]
Dumps showing what events the set of a column name cause.
Comment 5 Jiri Rechtacek 2009-05-26 10:32:28 UTC
The fix is coming...
Comment 6 Jiri Rechtacek 2009-05-26 11:46:26 UTC
http://hg.netbeans.org/core-main/rev/9c8e162b750d
Comment 7 Stanislav Aubrecht 2009-05-26 12:51:05 UTC
i've reviewed the fix and it looks ok to me
Comment 8 Jiri Rechtacek 2009-05-26 13:01:51 UTC
Filip, Martin please verify the fix in
http://deadlock.netbeans.org/hudson/job/NB-Core-Build/lastSuccessfulBuild/artifact/nbbuild/NetBeans-dev-NB-Core-Build-2682-on-090526-full.zip
ASAP. I'm going to integrate it in release67 before final RC1 build. Thanks
Comment 9 Filip Zamboj 2009-05-26 13:17:31 UTC
fine for me. waiting for martin. 
Comment 10 Martin Entlicher 2009-05-26 13:32:58 UTC
Fine for me as well. Thanks.
Comment 11 Jiri Rechtacek 2009-05-26 14:27:50 UTC
the fix was backported into release67: http://hg.netbeans.org/release67/rev/fe347444b5f7
Comment 12 Martin Entlicher 2009-05-26 14:50:36 UTC
*** Issue 165910 has been marked as a duplicate of this issue. ***
Comment 13 Martin Entlicher 2009-05-26 14:53:30 UTC
*** Issue 165821 has been marked as a duplicate of this issue. ***
Comment 14 Quality Engineering 2009-05-27 07:24:11 UTC
Integrated into 'main-golden', will be available in build *200905270201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9c8e162b750d
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #165934: Wrong column order in debugger views
Comment 15 Filip Zamboj 2009-05-27 10:58:47 UTC
verified in new rc1 

Product Version: NetBeans IDE 6.7 RC1 (Build 200905270001)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo