Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165890 - [67cat] java.io.EOFException: Can not read response from server. Expected to read 4 bytes, read 0 bytes before connection was unexpectedly lost.
[67cat] java.io.EOFException: Can not read response from server. Expected to ...
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 7.2
Assigned To: Jaroslav Havlin
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks: 152673
  Show dependency treegraph
 
Reported: 2009-05-24 05:35 UTC by esmithbss
Modified: 2012-05-21 08:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.75 KB, text/plain)
2009-05-24 05:35 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-05-24 05:35:35 UTC
Build: NetBeans IDE Dev (Build 200905211401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-12-generic, i386

User Comments:
GUEST: trying to access table struture inside the Services tab

esmithbss: Expanding a table node for a MySql database within the Services panel.  I believe the database connection was closed long ago, but the tree remained in the panel so I just clicked on the table node to expand it and view the fields.



Stacktrace: 
org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbeans.modules.db.metadata.model.api.MetadataException: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

Last packet sent to the server was 158 ms ago.
        at org.netbeans.modules.db.metadata.model.JDBCConnMetadataModel.runReadAction(JDBCConnMetadataModel.java:99)
        at org.netbeans.modules.db.metadata.model.api.MetadataModel.runReadAction(MetadataModel.java:89)
        at org.netbeans.modules.db.explorer.node.ColumnNodeProvider.initialize(ColumnNodeProvider.java:98)
        at org.netbeans.api.db.explorer.node.NodeProvider.getNodes(NodeProvider.java:103)
        at org.netbeans.modules.db.explorer.node.NodeRegistry.getNodes(NodeRegistry.java:149)
        at org.netbeans.api.db.explorer.node.ChildNodeFactory.createKeys(ChildNodeFactory.java:104)
Comment 1 esmithbss 2009-05-24 05:35:41 UTC
Created attachment 82702 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-10-08 21:39:43 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=150348
Comment 3 Jaroslav Havlin 2012-05-21 08:09:14 UTC
Cannot reproduce. Probably related to bug 165623.
Please reopen if you encounter the problem again. Thank you.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo