Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165802 - NullPointerException at com.sun.tools.javac.comp.Lower.visitApply
NullPointerException at com.sun.tools.javac.comp.Lower.visitApply
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 12:38 UTC by bburette
Modified: 2009-07-16 15:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.78 KB, text/plain)
2009-05-22 12:38 UTC, bburette
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bburette 2009-05-22 12:38:24 UTC
This issue was originally marked as duplicate of issue 159166, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 200905210001)
VM: Java HotSpot(TM) Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
bburette: In the IDE in a source file done a control-click on the class name "Enum" to jump to it's definition.



Stacktrace: 
java.lang.NullPointerException
        at com.sun.tools.javac.comp.Lower.visitApply(Lower.java:2544)
        at com.sun.tools.javac.tree.JCTree$JCMethodInvocation.accept(JCTree.java:1299)
        at com.sun.tools.javac.tree.TreeTranslator.translate(TreeTranslator.java:58)
        at com.sun.tools.javac.comp.Lower.translate(Lower.java:1916)
        at com.sun.tools.javac.tree.TreeTranslator.visitExec(TreeTranslator.java:242)
        at com.sun.tools.javac.tree.JCTree$JCExpressionStatement.accept(JCTree.java:1145)
Comment 1 bburette 2009-05-22 12:38:30 UTC
Created attachment 82633 [details]
stacktrace
Comment 2 Dusan Balek 2009-06-09 15:51:00 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/443e73eb4da1

changeset 82f86f47ec08 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=82f86f47ec08
Comment 3 Quality Engineering 2009-06-11 08:49:23 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/443e73eb4da1
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #165802: NullPointerException at com.sun.tools.javac.comp.Lower.visitApply - fixed.
Comment 4 Petr Blaha 2009-07-02 13:35:17 UTC
v.
Comment 5 pgebauer 2009-07-08 17:11:50 UTC
The fix has been ported into the release67_fixes repository together with issue 164833
http://hg.netbeans.org/release67_fixes/rev/6dbba45d6ea2
Comment 6 Jiri Prox 2009-07-16 15:29:30 UTC
v in 6.7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo