Bug 165580 - ClassCastException: javax.swing.plaf.nimbus.TabbedPaneTabbedPaneTabAreaPainter cannot be cast to com.sun.java.swing.Painter
ClassCastException: javax.swing.plaf.nimbus.TabbedPaneTabbedPaneTabAreaPainte...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
: REGRESSION, VISUALVM
: 165582 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 10:33 UTC by martinhavle
Modified: 2009-07-16 14:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.57 KB, text/plain)
2009-05-20 10:34 UTC, martinhavle
Details
stacktrace (2.57 KB, text/plain)
2009-05-20 10:36 UTC, martinhavle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martinhavle 2009-05-20 10:33:58 UTC
Build: NetBeans IDE Dev (Build 200905200201)
VM: Java HotSpot(TM) Client VM, 16.0-b02, Java(TM) SE Runtime Environment, 1.7.0-ea-b57
OS: Windows XP, 5.1, x86

User Comments:
martinhavle: Tried to run netbeans with param --laf Nimbus

martinhavle: Occured when trying to run ide with param --laf Nimbus



Stacktrace: 
java.lang.ClassCastException: javax.swing.plaf.nimbus.TabbedPaneTabbedPaneTabAreaPainter cannot be cast to com.sun.java.swing.Painter
        at org.netbeans.swing.tabcontrol.plaf.NimbusEditorTabDisplayerUI.paintBackground(NimbusEditorTabDisplayerUI.java:115)
        at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI.paint(BasicTabDisplayerUI.java:363)
        at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
        at javax.swing.JComponent.paintComponent(JComponent.java:778)
        at javax.swing.JComponent.paint(JComponent.java:1042)
        at javax.swing.JComponent.paintChildren(JComponent.java:879)
Comment 1 martinhavle 2009-05-20 10:34:03 UTC
Created attachment 82457 [details]
stacktrace
Comment 2 martinhavle 2009-05-20 10:36:00 UTC
Build: NetBeans IDE Dev (Build 200905200201)
VM: Java HotSpot(TM) Client VM, 16.0-b02, Java(TM) SE Runtime Environment, 1.7.0-ea-b57
OS: Windows XP, 5.1, x86

User Comments: 
Occured when trying to run ide with param --laf Nimbus

Stacktrace: 
java.lang.ClassCastException: javax.swing.plaf.nimbus.TabbedPaneTabbedPaneTabAreaPainter cannot be cast to com.sun.java.swing.Painter
        at org.netbeans.swing.tabcontrol.plaf.NimbusEditorTabDisplayerUI.paintBackground(NimbusEditorTabDisplayerUI.java:115)
        at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI.paint(BasicTabDisplayerUI.java:363)
        at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
        at javax.swing.JComponent.paintComponent(JComponent.java:778)
        at javax.swing.JComponent.paint(JComponent.java:1042)
        at javax.swing.JComponent.paintChildren(JComponent.java:879)
Comment 3 martinhavle 2009-05-20 10:36:04 UTC
Created attachment 82459 [details]
stacktrace
Comment 4 Stanislav Aubrecht 2009-05-20 11:02:55 UTC
probably an issue in jdk 1.7
Comment 5 Stanislav Aubrecht 2009-05-20 11:03:52 UTC
*** Issue 165582 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Sedlacek 2009-06-25 17:10:33 UTC
Product Version         = NetBeans IDE 6.7 (Build 200906212001)
Operating System        = Windows Vista version 6.0 running on x86
Java; VM; Vendor        = 1.7.0-ea; Java HotSpot(TM) Client VM 16.0-b03; Sun Microsystems Inc.
Runtime                 = Java(TM) SE Runtime Environment 1.7.0-ea-b59

Reproduced when starting NB 6.7 / VisualVM devbuilds with '--ui Nimbus' switch.

This is a regression on NetBeans side - used to work fine with NetBeans 6.5/VisualVM 1.1.1, but now breaks NetBeans
6.7/upcoming VisualVM version.

Fix for VisualVM is urgently needed.
Comment 7 Tomas Hurka 2009-06-25 17:55:09 UTC
In JDK 7 javax.swing.plaf.nimbus.TabbedPaneTabbedPaneTabAreaPainter implements javax.swing.Painter instead of com.sun.java.swing.Painter.
javax.swing.Painter is new in JDK 7 from build 57 see http://hg.openjdk.java.net/jdk7/tl/jdk/diff/7f45fcc04f8e/src/share/classes/javax/swing/Painter.java
Comment 8 Exceptions Reporter 2009-07-06 06:07:46 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=151504
Comment 9 Stanislav Aubrecht 2009-07-07 09:13:17 UTC
fixed

core-main 4dd45a9d78ad
Comment 10 Marian Mirilovic 2009-07-07 11:01:47 UTC
Martin / Jirka, please verify ... to get this into Patch 1.
Comment 11 Jiri Sedlacek 2009-07-07 12:00:46 UTC
Verified in NetBeans IDE Dev (Build NB-Core-Build-2872-on-090707) / VisualVM using the platform.
Comment 12 pgebauer 2009-07-07 15:55:23 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/01051413bfda
Comment 13 Quality Engineering 2009-07-07 17:31:35 UTC
Integrated into 'main-golden', will be available in build *200907071400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4dd45a9d78ad
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #165580 - class cast exception in jdk1.7
Comment 14 pribyl 2009-07-16 14:01:17 UTC
Product Version: NetBeans IDE Dev (Build 200907160201)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 16.0-b03
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Verified in 6.7.1 RC


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo