Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165579 - Refactoring of loop labels doesn't work
Refactoring of loop labels doesn't work
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 7.4
Assigned To: Ralph Ruijs
issues@java
:
: 173305 203121 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 10:17 UTC by alex108
Modified: 2013-05-22 11:06 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex108 2009-05-20 10:17:50 UTC
When I tried to refactor (via Ctrl+R) loop label in code I had found that it is impossible in current version of NB.
If it is possible, please add this feature.

Thanks a lot,
Alexey Makhov.
Comment 1 Jan Pokorsky 2009-05-20 12:29:29 UTC
Reproducible, it has not been implemented yet.
Comment 2 Jan Becicka 2011-03-28 12:15:18 UTC
*** Bug 173305 has been marked as a duplicate of this bug. ***
Comment 3 Ralph Ruijs 2013-01-10 17:20:04 UTC
*** Bug 203121 has been marked as a duplicate of this bug. ***
Comment 4 Ralph Ruijs 2013-03-05 16:14:07 UTC
Changeset: e76652710411
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2013-03-05 17:13
Comment 5 Quality Engineering 2013-03-07 01:57:19 UTC
Integrated into 'main-golden', will be available in build *201303062300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e76652710411
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #165579 - Refactoring of loop labels doesn't work


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo