Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 16542 - Use MouseOver events to make UI more productive
Use MouseOver events to make UI more productive
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P4 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: UI
: 20468 20642 (view as bug list)
Depends on: 29447
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-12 19:48 UTC by _ gtzabari
Modified: 2008-12-22 16:58 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2001-10-12 19:48:11 UTC
Say we have a combobox element in TOOLS -> OPTIONS.

Right now we need to single click on the combobox to give it focus, then single 
click on it a second time to get it to display all possible values. I strongly 
believe we can remove the need for the first click.

We should modify the UI across all of Netbeans such that any item having the 
mouse over it gains "virtual focus" which is NOT equivilent to real focus.. 

Basically put, if I am in Combobox A and I move the mouse over Combobox B, 
combobox B will look/feel like I have focus on it (ie: I can single-click to 
get a list of options) but hereby lies the difference between "virtual focus" 
and actual focus. In the case of a real focus change, when I move from combobox 
A to combobox B, I save my settings for combobox A (because I left it), but in 
the case of "virtual focus", combobox A doesn't save it settings or lose 
its "real focus" until after I click on combobox A.

If you need any more clarification on what I mean, please ask. I think this 
change will make Netbeans much more intuitive and productive to use.
Comment 1 Jan Chalupa 2001-11-27 11:51:19 UTC
Target milestone -> 3.3.1.
Comment 2 Jan Chalupa 2001-11-27 11:54:46 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2002-01-11 14:05:53 UTC
Target milestone -> 3.4
Comment 4 Jan Chalupa 2002-01-11 14:09:10 UTC
Target milestone -> 3.4
Comment 5 Jan Chalupa 2002-01-11 14:09:58 UTC
Target milestone -> 3.4
Comment 6 Jan Chalupa 2002-01-11 14:12:21 UTC
Target milestone -> 3.4
Comment 7 David Simonek 2002-01-29 17:51:58 UTC
I believe this is more a bug either in property sheet itself or in
focus transferring. Single click on combo works ok in regular
situations, and it should work here as well. David, please provide
further evaluation, thanks.
Comment 8 David Strupl 2002-01-30 09:31:46 UTC
PropertySheet (PropertyPanel/SheetButton more precisely) works this way:
1. It is in so called read state
2. first click --> goes to so called write state
  if the write state is combo --> show the combo, but collapsed
3. second click --> expand the combo

We might want to avoid the first click. I am not sure we want it.
Maybe the "plastic" option might by used to indicate this.

But anyway - this is clearly property sheet request for enhancement.
Comment 9 David Simonek 2002-02-05 14:44:33 UTC
It seems reasonable to me, and probably easily implementable.
UI team, what do you think and what is common behaviour of combo boxes
in property sheets in other IDE products?
Comment 10 Jiri Rechtacek 2002-02-07 17:26:17 UTC
For me the effort required is not adequate to the expected benefit of
this so I postponed it in future. It would nice to have in future if
time/resources would allow.
Comment 11 Jiri Rechtacek 2002-02-13 14:37:12 UTC
*** Issue 20468 has been marked as a duplicate of this issue. ***
Comment 12 Jiri Rechtacek 2002-07-23 15:38:29 UTC
*** Issue 20642 has been marked as a duplicate of this issue. ***
Comment 13 Marian Mirilovic 2003-01-17 12:50:39 UTC
Property sheet issue, as i know Tim is working on this.

Tim, it is available in the new implementation of Property Sheet,
isn't it ?
Comment 14 _ tboudreau 2003-01-17 15:25:09 UTC
This works in the new property sheet implementation, so it will
work in Options, which uses a PropertySheet.  

PropertyPanel (for example, the thing that you click to edit
editor colorings) will eventually be converted to use the 
new property sheet rendering infrastructure, which will 
take care of the rest of the two-clicks-to-drop-down
issues.

Adding dependency on property sheet rewrite umbrella issue.
Comment 15 _ tboudreau 2003-07-16 19:39:21 UTC
Fixed - new property sheet committed.
Comment 16 Marian Mirilovic 2003-07-18 13:54:07 UTC
verified in [nb_dev](20030718)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo