Bug 16535 - ArrayIndexOutOfBoundsException when trying to click on 'Data Type' property of some database connection table's column
ArrayIndexOutOfBoundsException when trying to click on 'Data Type' property o...
Status: CLOSED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Radko Najman
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-12 17:09 UTC by vnemec
Modified: 2003-06-30 17:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
exception stack trace (2.13 KB, text/plain)
2001-10-12 17:12 UTC, vnemec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vnemec 2001-10-12 17:09:14 UTC
[200110120100, jdk1.3.1, redhat7.1]

to reproduce:
a) create some database connection ('Explorer' - 'Runtime' tab -> 'Databases >
Drivers' - in contextual menu for some valid driver select 'Connect Using...')
b) expand connection's node
c) expand 'Tables' node
d) open properties od any of the table's columns
e) click 'Data Type' property

ArrayIndexOutOfBoundException is thrown - see attachment
Comment 1 vnemec 2001-10-12 17:12:53 UTC
Created attachment 3002 [details]
exception stack trace
Comment 2 Radko Najman 2001-10-18 14:14:46 UTC
Fixed (problem in DatabaseTypePropertyEditor).
Comment 3 David Kaspar 2002-11-18 15:16:52 UTC
Verified in main trunk
Comment 4 Quality Engineering 2003-06-30 17:18:01 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo