Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165319 - Cannot extract installation data (unpack200 finished with -1073741502 error code)
Cannot extract installation data (unpack200 finished with -1073741502 error c...
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 11:51 UTC by moses_jung
Modified: 2009-05-22 09:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Log file of Unpack200 finished with error for NB 6.5.1 (67.97 KB, text/plain)
2009-05-16 11:56 UTC, moses_jung
Details
Output file from running: c:\windows\system32\tasklist.exe -v > output.txt (19.85 KB, text/plain)
2009-05-20 03:37 UTC, moses_jung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description moses_jung 2009-05-16 11:51:46 UTC
Unable to install NB 6.5.1 on Windows Vista:

[2009-05-16 00:09:01.475]:         extracting C:\Program Files (x86)\NetBeans 6.5.1\platform9\modules\locale\org-
openide-util-enumerations_zh_CN.jar.pack.gz
[2009-05-16 00:09:01.477]:         executing command: C:\Program Files (x86)\Java\jre6\bin\unpack200.exe C:\Program 
Files (x86)\NetBeans 6.5.1\platform9\modules\locale\org-openide-util-enumerations_zh_CN.jar.pack.gz C:\Program Files 
(x86)\NetBeans 6.5.1\platform9\modules\locale\org-openide-util-enumerations_zh_CN.jar, in directory: .
[2009-05-16 00:09:01.487]:             [return]: -1073741502
[2009-05-16 00:09:01.487]:         ... command execution finished
[2009-05-16 00:09:01.487]:         org.netbeans.installer.utils.exceptions.InstallationException: Cannot extract 
installation data for Base IDE
[2009-05-16 00:09:01.487]:         	at org.netbeans.installer.product.components.Product.install(Product.java:291)
[2009-05-16 00:09:01.487]:         	at org.netbeans.installer.wizard.components.actions.InstallAction.execute
(InstallAction.java:152)
[2009-05-16 00:09:01.487]:         	at org.netbeans.installer.wizard.components.WizardAction$1.run
(WizardAction.java:120)
[2009-05-16 00:09:01.487]:         Caused by: java.io.IOException: Unpack200 finished with error
[2009-05-16 00:09:01.488]:         Error code: -1,073,741,502
[2009-05-16 00:09:01.488]:         Stdout: 
[2009-05-16 00:09:01.488]:         Stderr: 
[2009-05-16 00:09:01.488]:         	at org.netbeans.installer.utils.FileUtils.unpack(FileUtils.java:1184)
[2009-05-16 00:09:01.488]:         	at org.netbeans.installer.utils.FileUtils.extractByList(FileUtils.java:1705)
[2009-05-16 00:09:01.488]:         	at org.netbeans.installer.utils.FileUtils.extractAll(FileUtils.java:1625)
[2009-05-16 00:09:01.488]:         	at org.netbeans.installer.utils.FileUtils.unjar(FileUtils.java:1019)
[2009-05-16 00:09:01.488]:         	at org.netbeans.installer.product.components.Product.install(Product.java:281)
[2009-05-16 00:09:01.488]:         	... 2 more
[2009-05-16 00:09:01.489]:         Start rollback of Base IDE(nb-base/6.5.1.0.200903060201)
Comment 1 moses_jung 2009-05-16 11:56:54 UTC
Created attachment 82231 [details]
Log file of Unpack200 finished with error for NB 6.5.1
Comment 2 dlipin 2009-05-16 22:17:22 UTC
Kill Logitech Process Monitor (Webcam Effects Helper) application (LVPrcSrv.exe) and try again.

It is also mentioned in Release Notes (Issue 119861, Issue 117334)
http://www.netbeans.org/community/releases/65/1/relnotes.html#known_issues-installer

*** This issue has been marked as a duplicate of 117334 ***
Comment 3 moses_jung 2009-05-16 23:57:13 UTC
Reopening the issues:

I have disabled my antivirus software.
I have disabled my firewall.
I do not have the Logitech Process Monitor application (LVPrcSrv.exe) running.

I get this problem after doing all three of the above.
It is not reasonble to expect me to end processes.  I do not know what are all the "monitoring processes" that I need 
(or should) disable.

I have given you the log file of my error as an attachment to this problem ticket.

I can't even get the installer to install NB 6.5.1; much less use it!  Your product sucks.
Comment 4 dlipin 2009-05-19 14:34:06 UTC
please run (from command line)
c:\windows\system32\tasklist.exe -v > output.txt

and attach output.txt to this issue.
Comment 5 moses_jung 2009-05-20 03:37:20 UTC
Created attachment 82443 [details]
Output file from running: c:\windows\system32\tasklist.exe -v > output.txt
Comment 6 dlipin 2009-05-21 13:49:10 UTC
Hi,

I can`t say for sure which of the running programs cased such behaviour.
I would suggest to end all processes one by one and running installer again and again to identify the problematic one.
I agree with you that it is stupid and crazy but unfortunately that is the only way to find out the program that has 
such a bad and strange influence (we identified Logitech QuickCam service using such a method).
That would help other users in future to workaround similar problem quickly. We`ll also add that information in release 
notes.

You can also try a testing program to speed up the process.

Please download the following zip file:
http://www.netbeans.org/nonav/issues/showattachment.cgi/50271/testunpack.zip
extract it to the empty directory, goto to this directory and run
"C:\Program Files (x86)\Java\jre6\bin\java.exe" -jar unpack.jar 100
This test jar will try to unpack 3 packed files (that goes in the zip archive) for 100 times.
If it does not fail, increase the last argument (100) to 1000 or 5000. If it does not fail even for 5000 (and installer 
still fails) - please let me know I`ll tweak it to use problematic jars.

Then try to end all but the system the processes, one by one, and run this program after each ended process.
Start with ICO.EXE (Daemon Spy).

Thanks for your help.
Comment 7 dlipin 2009-05-22 09:50:50 UTC
Should be workarounded in the latest daily builds by http://hg.netbeans.org/main/rev/27186bdbdba9

http://bits.netbeans.org/netbeans/trunk/nightly/latest/


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo