Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165254 - runWhenScanFinished() runs task before scan is started
runWhenScanFinished() runs task before scan is started
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
fix-in-67
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 10:47 UTC by Pavel Flaska
Modified: 2009-05-18 18:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Tomas' profiler snapshot (53.43 KB, application/octet-stream)
2009-05-15 10:49 UTC, Pavel Flaska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Flaska 2009-05-15 10:47:20 UTC
User action task can be run before the initial scan (initial up-to-date check) is started. This was fixed in 6.5, perhaps re-introduced when Parsing API 
merged. It affects the startup and makes many complaints that scanning is slow.
Comment 1 Pavel Flaska 2009-05-15 10:49:54 UTC
Created attachment 82173 [details]
Tomas' profiler snapshot
Comment 2 Vitezslav Stejskal 2009-05-15 11:35:29 UTC
Pavle, what build did you test this on? This should be fixed by http://hg.netbeans.org/main-silver/rev/16603c975e4a,
could you please retest with build containing the fix? Thanks
Comment 3 Tomas Pavek 2009-05-15 12:13:29 UTC
The snapshot is from build 20090507. I'll try with the latest.
Comment 4 Pavel Flaska 2009-05-15 13:48:15 UTC
When tested manually, I can confirm that it works as expected, but will wait to Tomas' verification, because he was able to demonstrate the problem.
Comment 5 Pavel Flaska 2009-05-15 14:10:58 UTC
Profiler also shows that MainClassUpdater task is now run when scan is already finished. The issue is fixed.
Comment 6 Vitezslav Stejskal 2009-05-18 09:58:19 UTC
Ok, I'm closing it as FIXED. Tomasi please confirm or reopen. Thanks
Comment 7 Tomas Pavek 2009-05-18 18:25:32 UTC
Yes, it's better now (tested on 200905180201). The time after startup to get all project opening and scanning done 
dropped from ~30s to ~22s on the measured project. BTW in 6.5.1 this was 35s. (It is with closed task list.)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo