Bug 16491 - Stop using old Output Window
Stop using old Output Window
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: akemr
ivan
:
: 12925 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-12 07:45 UTC by Jaroslav Tulach
Modified: 2008-12-23 08:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2001-10-12 07:45:02 UTC
The old output window is still used in exception dialogs reported by
NbErrorManager (class NbException I guess). Please convert them to use term and
if there are no other usages of OutPane in core, etc. consider removing the code
completely.
Comment 1 akemr 2001-11-15 11:22:29 UTC
*** Issue 12925 has been marked as a duplicate of this issue. ***
Comment 2 Jan Chalupa 2001-11-27 11:52:07 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2001-11-27 11:55:59 UTC
Target milestone -> 3.3.1.
Comment 4 akemr 2001-12-07 10:32:30 UTC
First part implemented in release33 - NotifyException now uses 
terminal like OW
(I refactored OutputTabTerm to implement it)

Nobody uses old OW now, so next phase will be removing OutPane class..
Comment 5 akemr 2001-12-10 11:49:39 UTC
Fixed in release33 branch.

OutPane and OutputTab won't be used.
(see my task #18495 to remove them)
Comment 6 Lukas Hasik 2002-01-08 18:28:23 UTC
verified
Comment 7 Quality Engineering 2003-07-01 16:43:16 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2008-12-23 08:39:50 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo