Bug 164830 - UI message issues in Hudson integration
UI message issues in Hudson integration
Status: NEW
Product: connecteddeveloper
Classification: Unclassified
Component: Hudson
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Jaroslav Havlin
issues@connecteddeveloper
: UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 02:26 UTC by kohsuke
Modified: 2012-06-14 16:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kohsuke 2009-05-11 02:26:50 UTC
Japanese localization of Hudson features use terms like "構築ジョブ" and "継続的構築", but these are literal translation
of the words that are hard to understand (see http://d.hatena.ne.jp/shin/20090509/p1 for a comment from another user,
for example.)

I suggest the following changes:

構築ジョブ    ->     CIジョブ
継続的構築    ->     継続的インテグレーション or just "CI"
構築サーバー  ->     CIサーバ
Comment 1 Masaki Katakai 2009-05-14 03:48:54 UTC
I think we need to consider English labels too here.
It' not good idea to change just Japanese translations.

Actually it's hard to imagine Team->New Build Jobs... is
related with Hudson.

Create Build Job...
New Continuous Build
Build Server

Jesse, any idea?
Comment 2 Masaki Katakai 2009-05-15 05:29:00 UTC
Actually it would be hard to understand English UI itself.

Users can not find the name of Hudson until they open the dialog
by Team > New Build Job... It looks "Build" and "Hudson" are
being used together. No word in "Continuous Integration" in UI,
I can see it just in module description.

I think just "Hudson" or "Continuous Integration" word should
be used consistently on UI instead of just "Build".


These English will be translated into several languages,
at least Japanese, Chinese and Brazilian Portuguese.
So it's not good idea to take such workaround in these
languages at translation process.

Could you evaluate please?

Changed the component back to hudson.
Comment 3 Jesse Glick 2009-05-19 00:06:29 UTC
I'm just following the UI spec. No strong opinion on choice of terminology, though "Build Job" seems rather awkward.
Hudson itself uses "job" (or in a few cases "project") to represent what the menu item creates, whereas "build"
represents one numbered run of the job.
Comment 4 Jesse Glick 2009-05-19 03:00:22 UTC
Can probably be considered a UI defect; not sure about priority.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo