Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 164580 - IllegalArgumentException: Malformed \uxxxx encoding
IllegalArgumentException: Malformed \uxxxx encoding
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
67patch1-fixed
:
: 157161 163021 166299 166661 166735 166899 167775 167976 167977 (view as bug list)
Depends on: 167745
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 12:37 UTC by makpandian
Modified: 2009-07-10 17:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
LOG (41.91 KB, text/plain)
2009-05-06 12:39 UTC, makpandian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description makpandian 2009-05-06 12:37:53 UTC
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
	at java.util.Properties.loadConvert(Properties.java:552)
	at java.util.Properties.load0(Properties.java:374)
	at java.util.Properties.load(Properties.java:325)
	at org.netbeans.core.startup.preferences.PropertiesStorage.load(PropertiesStorage.java:201)
	at org.netbeans.core.startup.preferences.NbPreferences.properties(NbPreferences.java:188)
	at org.netbeans.core.startup.preferences.NbPreferences.getSpi(NbPreferences.java:110)
	at org.netbeans.core.startup.preferences.NbPreferences.put(NbPreferences.java:130)
	at java.util.prefs.AbstractPreferences.putLong(AbstractPreferences.java:396)
	at org.netbeans.modules.uihandler.Installer.<clinit>(Installer.java:203)
Caused: java.lang.ExceptionInInitializerError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at org.openide.util.SharedClassObject.createInstancePrivileged(SharedClassObject.java:641)
	at org.openide.util.SharedClassObject$SetAccessibleAction.run(SharedClassObject.java:1001)
	at org.openide.util.SharedClassObject$SetAccessibleAction.run(SharedClassObject.java:993)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.openide.util.SharedClassObject.findObject(SharedClassObject.java:515)
	at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:397)
	at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:340)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:906)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:428)
	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:364)
	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:276)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:165)
	at org.netbeans.core.startup.Main.start(Main.java:312)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:110)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 makpandian 2009-05-06 12:39:44 UTC
Created attachment 81636 [details]
LOG
Comment 2 mslama 2009-05-11 11:54:58 UTC
Please can you attach file $USERDIR/config/Preferences/org/netbeans/modules/uihandler.properties
Comment 3 mslama 2009-05-11 12:02:04 UTC
BTW do you use "\u" in your user name or password for exception reporter?
Comment 4 mslama 2009-05-14 15:48:08 UTC
"\u" should be escaped by NbPreferences. I do not see any possible problem with it.
Comment 5 mslama 2009-06-01 11:54:39 UTC
*** Issue 166299 has been marked as a duplicate of this issue. ***
Comment 6 Marian Mirilovic 2009-06-08 08:57:41 UTC
rising priority ... more duplicates are comming
Comment 7 Marian Mirilovic 2009-06-08 08:57:57 UTC
*** Issue 166661 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2009-06-08 09:14:15 UTC
*** Issue 157161 has been marked as a duplicate of this issue. ***
Comment 9 Marian Mirilovic 2009-06-08 09:16:30 UTC
*** Issue 163021 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Skrivanek 2009-06-08 12:24:37 UTC
In fact all keys and values are escaped in java.util.Properties.store. File
$USERDIR/config/Preferences/org/netbeans/modules/uihandler.properties had to be modified externally and exception points
that the key was wrong. It really helps if someone could attach uihandler.properties file. Otherwise I can just catch
the exception and remove broken file.
Comment 11 Jiri Skrivanek 2009-06-08 13:46:56 UTC
Fixed. IllegalArgumentException is caught and broken content of uihandler.properties file is rewritten afterwards.
core-main #6a4cd34dd7f2
Comment 12 Marian Mirilovic 2009-06-09 12:24:59 UTC
*** Issue 166735 has been marked as a duplicate of this issue. ***
Comment 13 Quality Engineering 2009-06-11 08:51:26 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6a4cd34dd7f2
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #164580 - ignore IllegalArgumentException: Malformed \uxxxx encoding.
Comment 14 Jiri Skrivanek 2009-06-15 12:00:32 UTC
*** Issue 166899 has been marked as a duplicate of this issue. ***
Comment 15 mslama 2009-07-02 12:52:01 UTC
*** Issue 167775 has been marked as a duplicate of this issue. ***
Comment 16 Petr Blaha 2009-07-03 09:53:08 UTC
makpandian, can you verify the fix in the latest trunk build that is available here
http://bits.netbeans.org/dev/nightly/latest/? Thanks
Comment 17 Marian Mirilovic 2009-07-07 09:57:09 UTC
v
Comment 18 pgebauer 2009-07-07 10:28:34 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/54dcb659bb77
Comment 19 mslama 2009-07-09 08:49:07 UTC
*** Issue 167977 has been marked as a duplicate of this issue. ***
Comment 20 Jesse Glick 2009-07-10 17:14:42 UTC
*** Issue 167976 has been marked as a duplicate of this issue. ***
Comment 21 Jesse Glick 2009-07-10 17:19:33 UTC
See also fix made in issue #167745 - the syntax error in that case causes the file to be deleted as it is loaded, rather
than when new keys are added. Probably my fix is better, but it has not been verified that I know of, and either should
suffice for the 6.7 backport.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo