Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 164550 - I18N : regression - localized javadoc will not be picked up at code completion and javadoc window
I18N : regression - localized javadoc will not be picked up at code completio...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
JA_COMMUNITY
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 04:05 UTC by Masaki Katakai
Modified: 2009-05-14 05:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Japaneese javadoc shown correctly on windows. (70.34 KB, image/png)
2009-05-06 13:42 UTC, Rastislav Komara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2009-05-06 04:05:17 UTC
NetBeans 6.7 Beta, Windows XP, JDK1.6.0_13

It seems that the issue 99487 is reproducible.

1. download "jdk-6u10-docs-ja.zip" from
   
   http://java.sun.com/javase/downloads/index.jsp
   Java SE 6 Documentation

2. Set the zip as Javadoc Tool > Java Platforms

3. Try code completion and Javadoc window

Now only English docs are displayed. It seems that the contents
are from src.zip file.

The behavior is the same when issue 99487 happened at 6.0.

working:

  Help -> Javadoc References
	can see localized javadoc title and can
	open it on browser

  Help -> Javadoc Index Search
	can search from localized javadoc,
	can display localized contents

not working, regression from 6.5: 6.5 is working well with the same zip.

  javadoc window with code completion window
	Only English docs (it looks it comes from src.zip) are
	displayed.

  javadoc window (Window -> Other -> Javadc)
	it displays only English.
   
In fact "jdk-6u10-docs-ja.zip" has been updated, but the
same zip file is working well on NB6.5.1.
Comment 1 Rastislav Komara 2009-05-06 13:42:07 UTC
Created attachment 81642 [details]
Japaneese javadoc shown correctly on windows.
Comment 2 Rastislav Komara 2009-05-06 13:43:22 UTC
Can't reproduce by provided steps.
Comment 3 Masaki Katakai 2009-05-07 03:39:47 UTC
Thank you very much Rastislav for the checking.

"String" is working for me too, I'm sorry I didn't notice.

Could you try "System.", "System.out." and "System.out.append()"?

It's working fine on nb6.5.1 but not working on 6.7 dev build.

I recorded the desktop.

http://blogs.sun.com/katakai/resource/nb67_jajavadoc_issue.htm
Comment 4 Dusan Balek 2009-05-07 08:09:06 UTC
Thanks for the reproducible test case. I'll look at it.
Comment 5 Dusan Balek 2009-05-07 09:01:07 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/4b38c4442186
Comment 6 Quality Engineering 2009-05-08 07:43:11 UTC
Integrated into 'main-golden', will be available in build *200905080201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4b38c4442186
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #164550: regression - localized javadoc will not be picked up at code completion and javadoc window - fixed.
Comment 7 Masaki Katakai 2009-05-14 05:33:40 UTC
Thank you very much Dusan for the fix!

I verified it's working fine on my environment. Marked as VERIFIED. Great!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo