Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 164368 - TestNG : not able to test single file
TestNG : not able to test single file
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 09:41 UTC by lforet
Modified: 2009-07-20 09:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Projects used to test (6.22 KB, application/x-compressed)
2009-05-05 11:20 UTC, lforet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lforet 2009-05-04 09:41:50 UTC
Using TestNG 5.8, With the 6.7 beta of Netbeans (maven support 4.1.2), I am not able to run test on a single file. I am 
obliged to test all the module. It tells me there is no test.

Furthermore, it will be very great super and wonderfull if I will be able to launch one single test. 

Thanks alot.
Comment 1 Milos Kleint 2009-05-05 08:45:24 UTC
could you attach a sample project? are you using the optional (alpha/beta) testng support? or only the default maven
support?
Comment 2 lforet 2009-05-05 10:47:33 UTC
It is very difficult to reproduce. Because sometimes it works. I try to find a receipe to make it always failed.

I will attach a sample project.
Comment 3 lforet 2009-05-05 11:20:02 UTC
Created attachment 81526 [details]
Projects used to test
Comment 4 lforet 2009-05-05 11:22:59 UTC
I play almost half an hour with the two projects  : modify poms use Ctl-Tab to swith test use clean and sometimes it 
does not launch test. It looks like we lost the focus on the file but not.


Comment 5 Milos Kleint 2009-06-04 08:26:42 UTC
http://hg.netbeans.org/main/rev/78383e7bdd6d

the testng tests cannot be executed via compile on save execution, we had the relevant condition there to exclude them
but the comparison method was wrong and didn't work. fixed.

in 6.7 it can be workarounded by disabling CoS for tests
Comment 6 lforet 2009-06-04 09:03:56 UTC
OK thanks ! turnaround seems to work with 6.7 RC1
Comment 7 Quality Engineering 2009-06-11 08:47:14 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/78383e7bdd6d
User: Milos Kleint <mkleint@netbeans.org>
Log: #164368 wrong comparison method used to exclude testng based tests from compile on save ant based execution
Comment 8 Jaroslav Pospisil 2009-06-25 15:40:19 UTC
v.
Comment 9 pgebauer 2009-07-02 12:04:21 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/87393a2db829
Comment 10 pribyl 2009-07-20 09:56:13 UTC
Product Version: NetBeans IDE 6.7.1 RC (Build 200907162301)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 16.0-b03
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Verified in 6.7.1 RC


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo