Bug 164366 - [67cat] AssertionError: variables(type: END_TAG) encountered
[67cat] AssertionError: variables(type: END_TAG) encountered
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Debugger
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 09:28 UTC by esmithbss
Modified: 2009-06-03 09:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (718 bytes, text/plain)
2009-05-04 09:28 UTC, esmithbss
Details
stacktrace (718 bytes, text/plain)
2009-05-11 05:03 UTC, esmithbss
Details
stacktrace (718 bytes, text/plain)
2009-05-27 08:56 UTC, esmithbss
Details
Log file with extra ruby debugging enabled. (152.81 KB, text/plain)
2009-05-27 09:10 UTC, esmithbss
Details
patched debug-commons-java-0.10.0.jar (144.85 KB, application/octet-stream)
2009-05-27 13:26 UTC, Erno Mononen
Details
debug-commons-java with proper fix (145.49 KB, application/octet-stream)
2009-06-01 21:21 UTC, Erno Mononen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-05-04 09:28:26 UTC
Build: NetBeans IDE Dev (Build 200905021401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.27-14-generic, i386

User Comments:
esmithbss: Expanding the self variable within the Variables pane for a RoR application.

GUEST: Debugging ruby code. Just clicked the step over button.



Stacktrace: 
java.lang.AssertionError: variables(type: END_TAG) encountered
        at org.rubyforge.debugcommons.reader.VariablesReader.parseVariables(VariablesReader.java:67)
        at org.rubyforge.debugcommons.reader.VariablesReader.parse(VariablesReader.java:48)
        at org.rubyforge.debugcommons.reader.VariablesReader.readVariables(VariablesReader.java:96)
        at org.rubyforge.debugcommons.ReadersSupport.processElement(ReadersSupport.java:156)
        at org.rubyforge.debugcommons.ReadersSupport.startXPPLoop(ReadersSupport.java:116)
        at org.rubyforge.debugcommons.ReadersSupport.access$200(ReadersSupport.java:44)
Comment 1 esmithbss 2009-05-04 09:28:31 UTC
Created attachment 81453 [details]
stacktrace
Comment 2 esmithbss 2009-05-11 05:02:57 UTC
Build: NetBeans IDE Dev (Build 200905071401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.27-14-generic, i386

User Comments: 
Stepping through a method within a Ruby On Rails model.

Stacktrace: 
java.lang.AssertionError: variables(type: END_TAG) encountered
        at org.rubyforge.debugcommons.reader.VariablesReader.parseVariables(VariablesReader.java:67)
        at org.rubyforge.debugcommons.reader.VariablesReader.parse(VariablesReader.java:48)
        at org.rubyforge.debugcommons.reader.VariablesReader.readVariables(VariablesReader.java:96)
        at org.rubyforge.debugcommons.ReadersSupport.processElement(ReadersSupport.java:156)
        at org.rubyforge.debugcommons.ReadersSupport.startXPPLoop(ReadersSupport.java:116)
        at org.rubyforge.debugcommons.ReadersSupport.access$200(ReadersSupport.java:44)
Comment 3 esmithbss 2009-05-11 05:03:16 UTC
Created attachment 81870 [details]
stacktrace
Comment 4 esmithbss 2009-05-27 08:56:07 UTC
Build: NetBeans IDE Dev (Build 200905260201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-12-generic, i386

User Comments: 
Expanding the self object within the ruby debugger.

Stacktrace: 
java.lang.AssertionError: variables(type: END_TAG) encountered
        at org.rubyforge.debugcommons.reader.VariablesReader.parseVariables(VariablesReader.java:67)
        at org.rubyforge.debugcommons.reader.VariablesReader.parse(VariablesReader.java:48)
        at org.rubyforge.debugcommons.reader.VariablesReader.readVariables(VariablesReader.java:96)
        at org.rubyforge.debugcommons.ReadersSupport.processElement(ReadersSupport.java:156)
        at org.rubyforge.debugcommons.ReadersSupport.startXPPLoop(ReadersSupport.java:116)
        at org.rubyforge.debugcommons.ReadersSupport.access$200(ReadersSupport.java:44)
Comment 5 esmithbss 2009-05-27 08:56:11 UTC
Created attachment 82838 [details]
stacktrace
Comment 6 esmithbss 2009-05-27 09:04:26 UTC
This also happens when I hold my mouse cursor over an object in the editor pane while debugging.

Attaching a log file from instance where debugger died due to trying to examine a variable in this way.  Also bumping
priority to p1 as this behavior is now a regression in debugger capabilities.
Comment 7 esmithbss 2009-05-27 09:09:30 UTC
The log file was generated with both extra ruby logging flags enabled in the options panel.

As you can see from the log file, this doesn't even generate a stack trace or similar.  The debugger just dies.
Comment 8 esmithbss 2009-05-27 09:10:27 UTC
Created attachment 82840 [details]
Log file with extra ruby debugging enabled.
Comment 9 Erno Mononen 2009-05-27 13:23:35 UTC
Most likely an issue in the backend; there was one change in the latest version of debug-commons-java that could be 
causing this. Anyway, I'm not able to reproduce this though, so I'm attaching here a patched version of debug-commons-
java that reverts the change - please give it a try if possible (just copy it to <nb_install_dir>ruby2/modules/ext and 
restart the IDE) and let me know whether that helps. Or if you can provide a sample file / project where this is 
reproducible that would be enough too. Thanks.
Comment 10 Erno Mononen 2009-05-27 13:26:14 UTC
Created attachment 82860 [details]
patched debug-commons-java-0.10.0.jar
Comment 11 Erno Mononen 2009-05-28 07:07:35 UTC
Waiting for feedback, so marking as incomplete for now.
Comment 12 Martin Schovanek 2009-05-28 17:49:24 UTC
esmithbss can you please test the fixed .jar?
Comment 13 Erno Mononen 2009-06-01 21:21:05 UTC
Created attachment 83083 [details]
debug-commons-java with proper fix
Comment 14 Erno Mononen 2009-06-01 21:33:01 UTC
Should be properly fixed now in 7f8ea969196c, and I've also attached the updated jar file here. The fix was in debug-
commons-java, http://rubyforge.org/pipermail/debug-commons-commits/2009-June/000352.html. 

Special thanks to mkrauskopf for tracking down the culprit and for reviewing the fix!
Comment 15 Quality Engineering 2009-06-02 08:42:59 UTC
Integrated into 'main-golden', will be available in build *200906020201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7f8ea969196c
User: Erno Mononen <emononen@netbeans.org>
Log: #164366: [67cat] AssertionError: variables(type: END_TAG) encountered
Comment 16 Petr Jiricka 2009-06-02 13:57:26 UTC
The reporter confirmed privately that Erno's patch fixes the problem, should be ported to 6.7. Removing the INCOMPLETE
keyword.
Comment 17 Tomasz Slota 2009-06-02 14:51:13 UTC
7f8ea969196c transplanted to 689c254c9d73 in release67

http://hg.netbeans.org/release67/rev/689c254c9d73

Comment 18 Martin Schovanek 2009-06-03 09:30:48 UTC
Verified in RC2 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo