Bug 164234 - Setting local repository to directory with space
Setting local repository to directory with space
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
: SPACE_IN_PATH
: 164303 164899 (view as bug list)
Depends on: 208065
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 17:52 UTC by summersb
Modified: 2012-02-20 19:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description summersb 2009-04-30 17:52:03 UTC
If I change my Local Repository in the options dialog to something with a space the build fails

NetBeans: Executing 'cmd /c C:\Program Files\apache-maven-2.1.0\bin\mvn.bat -Dnetbeans.execution=true
-Dmaven.repo.local=C:\Documents and Settings\summersb\.m2\repository install'
NetBeans:      JAVA_HOME =C:\Program Files\Java\jdk1.6.0_13
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.


I am using 6.7 Beta

If I leave the local repo empty (default) it works.
Comment 1 Milos Kleint 2009-05-06 09:46:39 UTC
http://hg.netbeans.org/main/rev/7e4af1007d3c

the problem was in execution via cmd /c (introduced by for for issue 153101)
now we quote the local path parameter (and maven command line path as well) so both shall work.
we also fallback to cmd /c only if access right problems occur.
Comment 2 Milos Kleint 2009-05-06 09:51:36 UTC
jpospisil: please test extensively and report any space in path problems on windows. thanks.
Comment 3 Jaroslav Pospisil 2009-05-06 10:13:35 UTC
Well, some of the space_in_path test cases are harder to reproduce on Win Vista, since default user directory, where .m2
repository folder is generated is different from XP version (C:\Documents and Settings\... versus C;\Users\...) and I
suspect i will find some of such issues when I switch to Win XP testing platform, which is planned soon. I will look at
this area thoroughly,at this time.
In this case,however, I think this issue could have cause similar to issue 161670 .
Comment 4 Milos Kleint 2009-05-06 10:20:16 UTC
yes, 161670 is related, I've made the fix more generic though.
Comment 5 Quality Engineering 2009-05-09 06:59:55 UTC
Integrated into 'main-golden', will be available in build *200905090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7e4af1007d3c
User: Milos Kleint <mkleint@netbeans.org>
Log: #164234, #153101 quote property values containing spaces on windows, use cmd /c for execution only if failing without it. cmd /c has negative effect of quoting property values
Comment 6 Milos Kleint 2009-05-11 12:48:10 UTC
*** Issue 164303 has been marked as a duplicate of this issue. ***
Comment 7 Milos Kleint 2009-05-12 09:27:13 UTC
*** Issue 164899 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo