Bug 164145 - IllegalStateException: The Java DB (Network) driver was not found
IllegalStateException: The Java DB (Network) driver was not found
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Derby
6.x
All All
: P3 (vote)
: 6.x
Assigned To: mohan30006
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, fix-in-67
:
: 152605 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 08:56 UTC by Petr Jiricka
Modified: 2012-01-25 04:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (550 bytes, text/plain)
2009-04-30 08:56 UTC, Petr Jiricka
Details
stacktrace (698 bytes, text/plain)
2009-10-20 03:38 UTC, moilejter
Details
java.lang.IllegalStateException: The Java DB (Network) driver was not found (1.52 KB, patch)
2012-01-25 04:38 UTC, mohan30006
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-04-30 08:56:40 UTC
This issue was originally marked as duplicate of issue 160558, that is already fixed. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments:
pjiricka: Installing the Facelets module from the 6.7 beta update center.



Stacktrace: 
java.lang.IllegalStateException: The Java DB (Network) driver was not found
        at org.netbeans.modules.derby.api.DerbyDatabases.registerDatabase(DerbyDatabases.java:362)
        at org.netbeans.modules.derby.api.DerbyDatabases.createSampleDatabase(DerbyDatabases.java:282)
        at org.netbeans.modules.glassfish.eecommon.api.RegisterDatabase$1.run(RegisterDatabase.java:95)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Petr Jiricka 2009-04-30 08:56:45 UTC
Created attachment 81275 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-04-30 15:19:41 UTC
*** Issue 152605 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Rechtacek 2009-06-18 11:29:25 UTC
I guess after the fix of issue 166750 it won't be reproducible anymore.
Comment 4 moilejter 2009-10-20 03:38:16 UTC
Build: NetBeans IDE 6.8 M2 (Build 200910071658)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02-90, Java(TM) SE Runtime Environment, 1.6.0_15-b03-219
OS: Mac OS X, 10.6.1, x86_64

User Comments: 


Stacktrace: 
java.lang.IllegalStateException: The Java DB (Network) driver was not found
        at org.netbeans.modules.derby.api.DerbyDatabases.registerDatabase(DerbyDatabases.java:362)
        at org.netbeans.modules.derby.api.DerbyDatabases.createSampleDatabase(DerbyDatabases.java:282)
        at org.netbeans.modules.glassfish.eecommon.api.RegisterDatabase$1.run(RegisterDatabase.java:95)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1084)
Comment 5 moilejter 2009-10-20 03:38:20 UTC
Created attachment 89726 [details]
stacktrace
Comment 6 mohan30006 2012-01-25 04:38:17 UTC
Created attachment 115216 [details]
java.lang.IllegalStateException: The Java DB (Network) driver was not found


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo