Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 164052 - 6.7 Beta 'scanning projects' does not complete
6.7 Beta 'scanning projects' does not complete
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
fix-in-67
:
Depends on: 161367
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 12:09 UTC by jrwhitley
Modified: 2009-05-13 16:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log of running out of memory (44.10 KB, text/plain)
2009-05-05 23:32 UTC, hof
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jrwhitley 2009-04-29 12:09:48 UTC
6.7 Beta: On launching, 'scanning projects' goes on indefinitely. top shows CPU < 10% 
Attempt to open source folders 'hangs'
File->Exit also hangs
Having been using 6.7 M3 successfully
Comment 1 jrwhitley 2009-04-30 09:32:20 UTC
6.7 Beta started working once I stopped it using the previous 6.5 stored configuration i.e. Reset netbeans up from
scratch and re-opened active projects
I also tried copying my existing 6.7M3 configuration to 6.5 but made no difference
Comment 2 hof 2009-05-05 19:56:35 UTC
Scanning Projects does not complete. Eventually runs out of memory. (Ubuntu 9.04 6.7 Beta) 
Comment 3 hof 2009-05-05 23:32:40 UTC
Created attachment 81598 [details]
messages.log of running out of memory
Comment 4 hof 2009-05-06 00:09:32 UTC
Note that i have projects that use other projects jar files with a relative path. 
Comment 5 Vitezslav Stejskal 2009-05-12 13:18:29 UTC
This could be the same as issue #161367. Is there any chance for us to replicate your projects setup? Or better, would
you be able to reproduce the problem on a self-contained example projects that you could send us for analysis? Also
there have been several important fixes in this area since 6.7beta could you please try using a recent dev build?

In order to further investigate this it would be great if you could run the IDE with the flag described at
http://wiki.netbeans.org/FaqMemoryDump, which will automatically generate a heapdump whenever OOME is thrown. Please let
me know (vstejskal@netbeans.org or through this issue) if you have a heap dump ready for upload and I'll let you know
where to upload it.

Another switch that could be useful is -J-Dorg.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.level=FINE,
which will turn on logging in repository updater. The log file is in <ide-userdir>/var/log/messages.log, please attach
it here after running the IDE with this switch and reproducing the issue. Thanks a lot
Comment 6 hof 2009-05-12 22:10:46 UTC
Not happening anymore with IDE Dev 200905121401 


Comment 7 Vitezslav Stejskal 2009-05-13 16:44:15 UTC
Ok, I'm closing this as FIXED, but please reopen if this happens again. Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo