Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 163977 - ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction
ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: Pluginportal
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jesse Glick
issues@updatecenters
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-fixed
:
Depends on:
Blocks: 161286
  Show dependency treegraph
 
Reported: 2009-04-28 21:23 UTC by deamonuy
Modified: 2009-08-17 07:32 UTC (History)
35 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.40 KB, text/plain)
2009-04-28 21:23 UTC, deamonuy
Details
stacktrace (2.38 KB, text/plain)
2009-06-02 15:35 UTC, rdelaplante
Details
stacktrace (2.38 KB, text/plain)
2009-06-12 16:53 UTC, rdelaplante
Details
stacktrace (2.39 KB, text/plain)
2009-06-15 01:49 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deamonuy 2009-04-28 21:23:11 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows Vista, 6.0, x86

User Comments:
GUEST: when im install plugin ireport 3.5. thats plugin cant function



Stacktrace: 
java.lang.ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction starting from SystemClassLoader[339 modules] with possible defining loaders [ModuleCL@ab1b4[org.netbeans.core]] and declared parents [ModuleCL@1555185[org.netbeans.modules.websvc.saas.services.amazon], ModuleCL@834cfb[org.netbeans.modules.xml.catalog], ModuleCL@162d950[org.netbeans.modules.editor.bookmarks], ModuleCL@f81402[org.netbeans.modules.tasklist.ui], ModuleCL@1cdfd19[org.netbeans.modules.xml.tools.java], ModuleCL@80ed90[org.netbeans.modules.websvc.jaxws21api], ModuleCL@174cb21[org.netbeans.libs.cglib], ModuleCL@257b34[org.netbeans.libs.swingx], ModuleCL@1c7d56b[org.netbeans.modules.versioning.util], ModuleCL@229ed4[org.netbeans.modules.uihandler.exceptionreporter], ...324 more]
        at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:259)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at org.openide.loaders.InstanceSupport.findClass(InstanceSupport.java:497)
        at org.openide.loaders.InstanceSupport.instanceClass(InstanceSupport.java:145)
        at org.openide.loaders.InstanceDataObject$Ser.instanceClass(InstanceDataObject.java:1228)
        at org.openide.loaders.InstanceDataObject.instanceClass(InstanceDataObject.java:738)
Comment 1 deamonuy 2009-04-28 21:23:23 UTC
Created attachment 81122 [details]
stacktrace
Comment 2 Jiri Skrivanek 2009-04-29 14:11:26 UTC
Please, could you give us detailed description? I don't know where to get ireport plugin. Step-by-step scenario would be
helpful.
Comment 3 Jaroslav Tulach 2009-04-29 14:15:04 UTC
I know Jesse moved the action to another module recently. Maybe the system is confused due to that?
Comment 4 Jesse Glick 2009-04-29 14:34:23 UTC
In 99eb1a5de1b6; it is now org.netbeans.core.ide.ServicesTabAction. I guess there could be a
META-INF/netbeans/translate.names for this, though I am not sure why you would have an old *.instance file for this menu
item to begin with, unless you have a very old user dir dating to when menu customization was still supported.
Comment 5 Jiri Skrivanek 2009-05-04 07:50:51 UTC
Probably incompatible jasper ireport plugin.
Comment 6 Jiri Kovalsky 2009-05-12 11:11:12 UTC
Giulio, can you please take a look at this? Thanks!
Comment 7 rdelaplante 2009-06-02 15:35:26 UTC
Build: NetBeans IDE 6.7 RC1 (Build 200905282243)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
I opened the IDE from desktop icon.  I see the start page.  About 10 projects are visible in the projects tab. 

Stacktrace: 
java.lang.ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction starting from SystemClassLoader[448 modules] with possible defining loaders [ModuleCL@487fb7[org.netbeans.core]] and declared parents [ModuleCL@1ff8de3[org.netbeans.modules.ant.kit], ModuleCL@a16605[org.netbeans.modules.websvc.wsstack.jaxws], ModuleCL@5bdfae[org.netbeans.modules.apisupport.refactoring], ModuleCL@2b7bd9[org.netbeans.modules.websvc.jaxwsmodel], ModuleCL@1cb2dd1[org.netbeans.modules.websvc.jaxrpc16], ModuleCL@1f13b08[org.netbeans.modules.db.kit], ModuleCL@73cc11[org.netbeans.libs.freemarker], ModuleCL@166ce5f[org.netbeans.modules.xml.jaxb], ModuleCL@30e4a7[org.netbeans.modules.welcome], ModuleCL@1af7a03[org.netbeans.modules.sendopts], ...433 more]
        at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:259)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at org.openide.loaders.InstanceSupport.findClass(InstanceSupport.java:497)
        at org.openide.loaders.InstanceSupport.instanceClass(InstanceSupport.java:145)
        at org.openide.loaders.InstanceDataObject$Ser.instanceClass(InstanceDataObject.java:1228)
        at org.openide.loaders.InstanceDataObject.instanceClass(InstanceDataObject.java:738)
Comment 8 rdelaplante 2009-06-02 15:35:31 UTC
Created attachment 83107 [details]
stacktrace
Comment 9 Quality Engineering 2009-06-03 18:44:20 UTC
Integrated into 'main-golden', will be available in build *200906031401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/28d8d7e8827f
User: Jesse Glick <jglick@netbeans.org>
Log: Downgrade CNFE thrown when a *.instance file for a nonexistent class is encountered.
Also try to clean up (if a file present in userdir). Could be helpful with issues like #163977.
Comment 10 stinnux 2009-06-05 14:36:04 UTC
In case you still need it, the plugin can be downloaded here:

http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=4425
Comment 11 rdelaplante 2009-06-12 16:53:24 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
Opened the IDe, opened a facelets .xhtml page

Stacktrace: 
java.lang.ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(AccessController.java:0)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
Comment 12 rdelaplante 2009-06-12 16:53:33 UTC
Created attachment 83517 [details]
stacktrace
Comment 13 rdelaplante 2009-06-15 01:49:03 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
I opened the IDE.  There are a bunch of editor tabs open for .xml, .css and .xhtml files

Stacktrace: 
java.lang.ClassNotFoundException: org.netbeans.core.actions.ViewRuntimeTabAction
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(AccessController.java:0)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
Comment 14 rdelaplante 2009-06-15 01:49:08 UTC
Created attachment 83564 [details]
stacktrace
Comment 15 Marian Mirilovic 2009-06-15 11:58:11 UTC
108 duplicates and still coming 
Comment 16 Jesse Glick 2009-06-16 16:52:58 UTC
iReport plugin produces tons of other warnings, but there is no apparent response from the owner. I will try to
reproduce and see if my trunk patch made things any better.
Comment 17 Jesse Glick 2009-06-16 17:06:30 UTC
For some reason I cannot fathom, com/jaspersoft/ireport/layer.xml has

<file name="ViewRuntimeTabAction.shadow">
    <attr name="originalFile" stringvalue="Actions/Window/org-netbeans-core-actions-ViewRuntimeTabAction.instance"/>
    <attr name="position" intvalue="300"/>
</file>

My 28d8d7e8827f (in trunk) does help - the exception is printed only to the log file. Unfortunately it is still printed
many times (along with various other errors in the iReport modules), and because the mistake is in the layer rather than
the userdir, it does not get autocorrected.
Comment 18 Jesse Glick 2009-06-16 17:36:20 UTC
Filed origin bug: https://sourceforge.net/tracker/?func=detail&aid=2807250&group_id=64348&atid=1121503

Introduced a translation for this class name: core-main #c52c623e6e65

This is parented to the refactoring changeset, so could be pulled directly into release67 if desired. Just let me know.
Comment 19 Quality Engineering 2009-06-17 08:32:41 UTC
Integrated into 'main-golden', will be available in build *200906170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c52c623e6e65
User: Jesse Glick <jglick@netbeans.org>
Log: #163977: translation for ViewRuntimeTabAction.
Comment 20 Petr Blaha 2009-07-02 10:54:21 UTC
I can't reproduce the exception in the latest NB build (090702) and the IReport available on pluginportal, closing the
issue as verified.
Comment 21 pgebauer 2009-07-03 12:12:31 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/ce1d74bdabc8
Comment 22 gt78 2009-07-09 09:04:37 UTC
Just in case, the problem has been fixed in iReport too, the fix will be released with the next version of the plugin 
(3.2.3) scheduled for end of July.

Thanks guys.

Giulio
Comment 23 Jiri Kovalsky 2009-07-09 10:07:19 UTC
Thanks a lot for the update Giulio!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo