Bug 163808 - IllegalArgumentException: Illegal pattern character 'A'
IllegalArgumentException: Illegal pattern character 'A'
Status: RESOLVED INVALID
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P2 (vote)
: TBD
Assigned To: Petr Cyhelsky
issues@profiler
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: I18N
: 163816 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 19:42 UTC by Ivan Sidorkin
Modified: 2009-04-28 09:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.71 KB, text/plain)
2009-04-27 19:42 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-04-27 19:42:53 UTC
Build: NetBeans IDE Dev (Build 200904240201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.ExceptionInInitializerError
        at org.netbeans.modules.profiler.SnapshotInfoPanel.updateInfo(SnapshotInfoPanel.java:204)
        at org.netbeans.modules.profiler.SnapshotInfoPanel.<init>(SnapshotInfoPanel.java:179)
        at org.netbeans.modules.profiler.CPUSnapshotPanel.<init>(CPUSnapshotPanel.java:369)
        at org.netbeans.modules.profiler.SnapshotResultsWindow.displayCPUResults(SnapshotResultsWindow.java:337)
        at org.netbeans.modules.profiler.SnapshotResultsWindow.<init>(SnapshotResultsWindow.java:174)
        at org.netbeans.modules.profiler.SnapshotResultsWindow.get(SnapshotResultsWindow.java:224)
Comment 1 Ivan Sidorkin 2009-04-27 19:42:58 UTC
Created attachment 81006 [details]
stacktrace
Comment 2 Petr Cyhelsky 2009-04-28 07:09:40 UTC
The exception occurred in jdk when parsing "��AAA�n" string added to the beginning of the date pattern from bundle. Were
you using some special build for I18N testing purposes or were you just using some strange locale(which one?)?
Comment 3 Ivan Sidorkin 2009-04-28 07:14:30 UTC
locale  System Locale; Encoding = ja_JP (nb); MS932
the same problem as 163816
can't start profile session 

Michal, please provide more build info
Comment 4 Marian Mirilovic 2009-04-28 07:20:39 UTC
rising priority - looks like we have serious problem with other locales

Michal, please help with evaluation.
Comment 5 Petr Cyhelsky 2009-04-28 07:47:27 UTC
*** Issue 163816 has been marked as a duplicate of this issue. ***
Comment 6 Petr Cyhelsky 2009-04-28 07:47:51 UTC
*** Issue 163821 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Hurka 2009-04-28 07:48:15 UTC
This problem is caused by incorrect localization, which blindly adds text in front of and behind every text in Bundle.properties
Closing as invalid.
Comment 8 Petr Cyhelsky 2009-04-28 07:55:01 UTC
changing to invalid
Comment 9 Petr Cyhelsky 2009-04-28 07:55:19 UTC
changing to invalid
Comment 10 mvanek 2009-04-28 08:59:59 UTC
Masaki, can you check pseudo-locale bundle for profiler?
thanks
Comment 11 Ivan Sidorkin 2009-04-28 09:13:41 UTC
issue is not invalid by itself. 
profiler doesn't work, so it should be reassigned to person who by mistake updated properties in bundle
or if these properties was not marked to exclude from l10n process it is profiler issue
Tomas, was this bundle marked that it shouldn't be translated?
Comment 12 Tomas Hurka 2009-04-28 09:20:21 UTC
Bundle should be translated. Doing "blind" translation, with adding text in front of and behind every text is wrong.
Comment 13 Masaki Katakai 2009-04-28 09:26:11 UTC
It's my fault, very sorry for that. I'll check these entires carefully.

Yes, these entries can be localized, date format is depending on language.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo