Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 163805 - [67cat] SQL history doesn't insert the selected history when filtering results
[67cat] SQL history doesn't insert the selected history when filtering results
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
PC Linux
: P2 with 2 votes (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
: NETFIX, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 18:59 UTC by Michel Graciano
Modified: 2009-05-04 15:39 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (4.71 KB, patch)
2009-04-28 03:21 UTC, Michel Graciano
Details | Diff
New patch to solve multiple connections issue (6.09 KB, patch)
2009-04-29 15:31 UTC, Michel Graciano
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2009-04-27 18:59:06 UTC
[ BUILD # : 200904231401 ]
[ JDK VERSION : 1.6.* ]

When I filter the results, and select the first line for example, and
click Insert, the code inserted is the first result from the original
query.
Comment 1 Michel Graciano 2009-04-28 03:00:02 UTC
It is a regression of issue http://www.netbeans.org/issues/show_bug.cgi?id=151634
I am testing an patch that I hope to attach here soon.
I want to request this issue to be fixed by NetFIX program, is that ok for you?

Regards
Comment 2 Michel Graciano 2009-04-28 03:20:27 UTC
The problem about issue #151634 is just because sortCol and sortAsc was defined to order by sql instead date and in
incorrect order. I changed it to avoid regression against this issue. I refactored some unnecessary code to avoid future
regressions. I hope the patch is acceptable. Comments are welcome.

Regards
Comment 3 Michel Graciano 2009-04-28 03:21:22 UTC
Created attachment 81023 [details]
Proposed patch
Comment 4 Jiri Rechtacek 2009-04-28 11:21:34 UTC
Confirmed this bug in NetBeans IDE Dev (Build 090427). The issue has not such weight to be P1, I decrease to P2 because
it's a regression.
Comment 5 Jiri Rechtacek 2009-04-28 11:30:50 UTC
hmichel, thank you for catching this problem and fixing it. The patch was applied in core-main/rev/b6f4114f0b8b
Comment 6 Michel Graciano 2009-04-28 13:25:36 UTC
First of all, thanks for quick patch integration. BTW, I will not argue about priority now because it is already fixed,
but any regression is an P1 as guidelines, and this issue just make history panel unusable for me since my history is
really huge.

Regards
Comment 7 Quality Engineering 2009-04-29 07:19:54 UTC
Integrated into 'main-golden', will be available in build *200904290201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b6f4114f0b8b
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #163805: [67cat] SQL history doesn't insert the selected history when filtering results; applied hmichel's patch
Comment 8 Michel Graciano 2009-04-29 15:31:02 UTC
There is similar problem when using several connections and have the same SQL string for different connections. I fixed
the problem and will attach the new patch. The change is basically use the same code when combobox is changed (for combo
it works).
Comment 9 Michel Graciano 2009-04-29 15:31:53 UTC
Created attachment 81215 [details]
New patch to solve multiple connections issue
Comment 10 Jiri Rechtacek 2009-04-30 15:03:34 UTC
The second was applied in core-main/rev/555b20ba0ceb
Comment 11 Quality Engineering 2009-05-02 06:47:26 UTC
Integrated into 'main-golden', will be available in build *200905020201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/555b20ba0ceb
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #163805: [67cat] SQL history doesn't insert the selected history when filtering results; applied yet another hmichel's patch
Comment 12 Michel Graciano 2009-05-04 15:39:20 UTC
v. 200905031401

Thanks again for quickly patch integration.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo