Bug 163378 - deadlock while activating J2EE
deadlock while activating J2EE
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
Sun All
: P1 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
:
: 159467 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 12:51 UTC by Jindrich Sedek
Modified: 2009-04-23 08:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (26.35 KB, text/plain)
2009-04-22 12:52 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-04-22 12:51:54 UTC
I've tried to create new Web Project, the wizard got blocked during JAVA EE activation. see attached threaddump - seems 
to be problem in filesystems, please evaluate and reassign if needed
Comment 1 Jindrich Sedek 2009-04-22 12:52:21 UTC
Created attachment 80689 [details]
thread dump
Comment 2 Jiri Skrivanek 2009-04-22 13:01:12 UTC
Seems to be related to ergonomics.
Comment 3 Jaroslav Tulach 2009-04-22 13:06:29 UTC
It is not related to ergonomics at all. Should you have read the thread dump you would find out that the deadlock is 
on 0xafe78e50 - e.g. org.netbeans.modules.openide.filesystems.declmime.MIMEResolverImpl$Impl
Comment 4 Jindrich Sedek 2009-04-22 13:33:19 UTC
This issue should be fixed in beta -> P1
Comment 5 Jiri Skrivanek 2009-04-22 15:17:29 UTC
Fixed in trunk. I will merge it to beta.
http://hg.netbeans.org/core-main/rev/ad12303420bb
Comment 6 Jiri Skrivanek 2009-04-22 16:09:04 UTC
Pushed to release67_beta repository.
http://hg.netbeans.org/release67_beta/rev/ad12303420bb
Comment 7 Jaroslav Tulach 2009-04-23 05:48:32 UTC
*** Issue 159467 has been marked as a duplicate of this issue. ***
Comment 8 Jaroslav Tulach 2009-04-23 08:13:50 UTC
*** Issue 159467 has been marked as a duplicate of this issue. ***
Comment 9 Jindrich Sedek 2009-04-23 08:25:28 UTC
NetBeans IDE 6.7 Beta (Build 200904230001)
Comment 10 Quality Engineering 2009-04-23 08:56:56 UTC
Integrated into 'main-golden', will be available in build *200904230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ad12303420bb
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #163378 - not synchronize smell field to prevent deadlock.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo