Bug 163211 - AIOOBE during profiling application
AIOOBE during profiling application
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
: 164250 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 10:43 UTC by Ivan Sidorkin
Modified: 2009-06-16 10:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-04-21 10:43:06 UTC
Product Version: NetBeans IDE 6.7 Beta (Build 200904192254)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

- full installation
- create NetBeans Modules|FeedReader sample
- start CPU profiling with default settings
- in opened application right click on RSS/Atom Feeds node

java.lang.ArrayIndexOutOfBoundsException: -32401
	at org.netbeans.lib.profiler.server.ProfilerRuntimeCPUFullInstr.methodEntry(ProfilerRuntimeCPUFullInstr.java:171)
	at org.openide.nodes.CookieSet$PairWrap.<init>(CookieSet.java:658)
	at org.openide.nodes.NodeLookup.addCookie(NodeLookup.java:117)
	at org.openide.nodes.NodeLookup.updateLookupAsCookiesAreChanged(NodeLookup.java:191)
	at org.openide.nodes.NodeLookup.beforeLookup(NodeLookup.java:162)
Comment 1 Petr Cyhelsky 2009-04-21 16:17:36 UTC
Reproduced. Seems to be bug in JDK 1.6.10 and later - works fine with JDK 1.5 and JDK 1.6 up to and including update 7.
Comment 2 Tomas Hurka 2009-05-04 13:43:41 UTC
*** Issue 164250 has been marked as a duplicate of this issue. ***
Comment 3 Tomas Hurka 2009-05-04 16:04:00 UTC
This JVM bug can be reproduced with Server VM only.
Comment 4 Tomas Hurka 2009-05-07 13:06:51 UTC
The situation is as follow:
There seems to be a problem in JDK from the beginning. There is a workaround for this AIOOBE in the NetBeans Profiler code, but that workaround does not 
work with Server VM 1.6.0_10 and later. Due to improvements in HotSpot Server compiler workaround was eliminated as no-op when compiling (for example) org/netbeans/lib/profiler/server/ProfilerRuntimeCPUSampledInstr.methodEntry(). I will try to come up with another workaround, which will not be eliminated 
by HotSpot Server compiler. 
Comment 5 Tomas Hurka 2009-05-07 14:06:20 UTC
Fixed in profiler-main

changeset:   130108:15c5742b0f0d
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu May 07 15:00:02 2009 +0200
summary:     bugfix #163211, new workaround for the case where methodId is treated as short

changeset:   130109:0eb87fc103e2
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu May 07 15:02:06 2009 +0200
summary:     bugfix #163211, make sure that methodId is treated as char


Comment 6 Quality Engineering 2009-05-08 07:44:02 UTC
Integrated into 'main-golden', will be available in build *200905080201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/15c5742b0f0d
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #163211, new workaround for the case where methodId is treated as short
Comment 7 Ivan Sidorkin 2009-06-16 10:44:33 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo