Bug 163196 - might be because your user directory is on a Windows UNC path message
might be because your user directory is on a Windows UNC path message
Status: VERIFIED DUPLICATE of bug 163185
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Jan Jancura
issues@editor
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 08:51 UTC by Ivan Sidorkin
Modified: 2009-07-09 15:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-04-21 08:51:59 UTC
Product Version: NetBeans IDE 6.7 Beta (Build 200904192254)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

- full installation
- create PHP project
- create PHP class
- press Ctrl+Space inside class
- got two messages  "; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using
mapped drive letters."
-  also got this message during editing class.
it is absolutely impossible to work

may related to Issue 161053 or Issue 163001

msg
Caused: java.lang.IllegalArgumentException: Illegal character in path at index 18: file:/C:/Documents and
Settings/is153249/My Documents/NetBeansProjects/PhpProject10/PHPClass.php [file:/C:/Documents and Settings/is153249/My
Documents/NetBeansProjects/PhpProject10/PHPClass.php]
[catch] at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:122)
	at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:62)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:213)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.addIndexingJob(RepositoryUpdater.java:195)
	at org.netbeans.modules.parsing.api.indexing.IndexingManager.refreshIndexAndWait(IndexingManager.java:110)
	at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.query(QuerySupport.java:243)
	at org.netbeans.modules.php.editor.index.PHPIndex.search(PHPIndex.java:267)
	at org.netbeans.modules.php.editor.index.PHPIndex.getTypeSpecificSignatures(PHPIndex.java:668)
	at org.netbeans.modules.php.editor.index.PHPIndex.getTypeSpecificSignatures(PHPIndex.java:658)
	at org.netbeans.modules.php.editor.index.PHPIndex.getMethods(PHPIndex.java:593)
	at org.netbeans.modules.php.editor.PHPCodeCompletion.autoCompleteInClassContext(PHPCodeCompletion.java:710)
	at org.netbeans.modules.php.editor.PHPCodeCompletion.complete(PHPCodeCompletion.java:302)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.addCodeCompletionItems(GsfCompletionProvider.java:607)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.resolveCompletion(GsfCompletionProvider.java:595)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.access$400(GsfCompletionProvider.java:243)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery$1.run(GsfCompletionProvider.java:333)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:113)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:189)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.query(GsfCompletionProvider.java:319)
	at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
ALL [null]: ; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped
drive letters.
SEVERE [org.openide.util.Exceptions]

msg
Caused: java.lang.IllegalArgumentException: Illegal character in path at index 18: file:/C:/Documents and
Settings/is153249/My Documents/NetBeansProjects/PhpProject10/PHPClass.php [file:/C:/Documents and Settings/is153249/My
Documents/NetBeansProjects/PhpProject10/PHPClass.php]
[catch] at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:122)
	at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:62)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:213)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.addIndexingJob(RepositoryUpdater.java:195)
	at org.netbeans.modules.parsing.api.indexing.IndexingManager.refreshIndexAndWait(IndexingManager.java:110)
	at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.query(QuerySupport.java:243)
	at org.netbeans.modules.php.editor.index.PHPIndex.search(PHPIndex.java:267)
	at org.netbeans.modules.php.editor.index.PHPIndex.getTypeSpecificSignatures(PHPIndex.java:668)
	at org.netbeans.modules.php.editor.index.PHPIndex.getTypeSpecificSignatures(PHPIndex.java:658)
	at org.netbeans.modules.php.editor.index.PHPIndex.getMethods(PHPIndex.java:593)
	at org.netbeans.modules.php.editor.PHPCodeCompletion.autoCompleteInClassContext(PHPCodeCompletion.java:710)
	at org.netbeans.modules.php.editor.PHPCodeCompletion.complete(PHPCodeCompletion.java:302)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.addCodeCompletionItems(GsfCompletionProvider.java:607)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.resolveCompletion(GsfCompletionProvider.java:595)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.access$400(GsfCompletionProvider.java:243)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery$1.run(GsfCompletionProvider.java:333)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:113)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:189)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
	at
org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.query(GsfCompletionProvider.java:319)
	at org.netbeans.spi.editor.completion.support.AsyncCompletionTask.run(AsyncCompletionTask.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
ALL [null]: ; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped
drive letters.
Comment 1 Marian Mirilovic 2009-04-21 10:41:21 UTC
related to issue 163001 or issue 161053
Comment 2 Vitezslav Stejskal 2009-04-21 12:41:19 UTC

*** This issue has been marked as a duplicate of 163185 ***
Comment 3 Ivan Sidorkin 2009-07-09 15:50:36 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo