Bug 163043 - Properties: NB sets the project to MIDP 2.1 by itself
Properties: NB sets the project to MIDP 2.1 by itself
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
PC Windows Vista
: P1 (vote)
: 6.x
Assigned To: Denis Anisimov
issues@mobility
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-19 17:39 UTC by roplacebo
Modified: 2009-04-23 10:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description roplacebo 2009-04-19 17:39:51 UTC
Everytime I open the properties window in a mobile project, the device profile radio button sets itself to MIDP 2.1.
If I set it to 2.0 and choose OK the value will be written into the project.properties correctly.
But next time I open the properties, it says 2.1 again.

If I simply click OK, it will actually be set to 2.1.
This happens, when using WTK 2.5.2 and SonyEricsson SDK 2.5.0.3 but not with, for example, Nokia Series40 6th Edition.

The CLDC radio button also has a similiar behaviour.
Comment 1 Denis Anisimov 2009-04-20 08:36:48 UTC
It seems this is regression introduced via fix for 157499.
Method setDefault in CustomizerMIDP class is called when profile was changed by user.
But it shouldn't be called.
Comment 2 Denis Anisimov 2009-04-20 08:40:23 UTC
Notion about CLDC radio buttons: they don't have similar behavior.
I cannot reproduce this and source code doesn't have any related changes
for configurations profile. So fix for this issue will concern only platform
profile radio buttons.
If you really have issues with CLDC buttons please file another separate issue.
But please make sure that you really have an issue.
Comment 3 Denis Anisimov 2009-04-20 08:58:25 UTC
changeset:   127560:6adfb7a94637
user:        Denis Anisimov <ads@netbeans.org>
date:        Mon Apr 20 11:51:34 2009 +0400
summary:     Fix for IZ#163043 - Properties: NB sets the project to MIDP 2.1 by itself
Comment 4 Quality Engineering 2009-04-20 20:18:46 UTC
Integrated into 'main-golden', will be available in build *200904201507* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6adfb7a94637
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for IZ#163043 - Properties: NB sets the project to MIDP 2.1 by itself
Comment 5 Andrei Chistiakov 2009-04-21 10:23:05 UTC
This is a regression. I think the fix is worth integration in Beta.
Comment 6 Petr Suchomel 2009-04-21 11:14:33 UTC
I think, the patch could be:

Instead of reset = c.length>0; //fix for 157499 to do simply reset = true; //fix for 157499
     2.8              for (int i=0; i<c.length; i++) {
And keep the rest of code same. The problem was that reset was after (inside) for cycle.

Yes, it is wort to put into Beta.
Comment 7 Marian Mirilovic 2009-04-22 08:26:08 UTC
I haven't seen that integrated into release67_beta yet ... could you proceed with backport ?
Comment 8 Andrei Chistiakov 2009-04-22 14:22:06 UTC
The fix is pre-verified with NetBeans IDE Dev (Build 200904201507) from trunk.
Comment 9 Denis Anisimov 2009-04-22 17:51:33 UTC
Integration for 6.7 beta :
changeset:   127839:855559bf6a33
user:        Denis Anisimov <ads@netbeans.org>
date:        Wed Apr 22 20:48:40 2009 +0400
summary:     Fix for IZ#163043 - Properties: NB sets the project to MIDP 2.1 by itself
Comment 10 Andrei Chistiakov 2009-04-23 10:54:51 UTC
Verified with NetBeans IDE 6.7 Beta (Build 200904230001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo