Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 162780 - [67cat] [ergo] Installing plugins right after first start seriously breaks UI
[67cat] [ergo] Installing plugins right after first start seriously breaks UI
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@performance
:
: 167040 175148 (view as bug list)
Depends on: 169892
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 07:47 UTC by esmithbss
Modified: 2009-10-22 16:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-04-16 07:47:25 UTC
[ BUILD # : 200904150201 ]
[ JDK VERSION : 1.6.* ]

I installed the dev build expecting to do some SOA and Swing
development.  I added the SOA plugin and went in to create a Java
Desktop Application, but the only application under the Java types is
the Java Application which is a default app.  I wanted the GUI,etc to
be there automatically.

I had to go into the plugins and manually enable the GUI developer to
get the Java Desktop application type.
Comment 1 Jaroslav Tulach 2009-05-18 12:21:21 UTC
Installing SOA enables java.kit and the ergonomics system then thinks that the java functionality is enabled and 
disables all Java related fakes. A tax to pay due to decision that ergonomics operate on whole clusters. Impossible to 
fix the problem in 6.7 release, but I'll keep thinking about it for the future.
Comment 2 Antonin Nebuzelsky 2009-06-02 17:48:08 UTC
More serious than just a P3.

We encourage the users right after the first start in our Start Page to go and Install Plugins. If they do it (like
explained above with the SOA example), some modules from the disabled clusters get enabled. This breaks several
"Ergonomics entry points" - some New Project templates are missing in the wizard (e.g. the Java Desktop Application
mentioned here, and also the whole Maven project category), some projects are not recognized in Open Project dialog as
valid projects (e.g. all maven projects).

Easy steps to reproduce:
* start fresh 6.7 RC1
* click Install Plugins on the Start Page
* install SOA from the list
* restart as suggested
* open New Project wizard, or open Open Project dialog - Maven missing and maven projects not recognized, ...

As a new user, the only impression you get is the missing projects are not supported. I doubt assuming the user will go
to Plugin Manager and try enabling random features manually would be a viable workaround. These Ergonomics entry points
were specified as P1 entry points in the Ergo spec. Having them broken with such a straightforward user action has to be
fixed.
Comment 3 Tomas Pavek 2009-06-16 10:26:08 UTC
*** Issue 167040 has been marked as a duplicate of this issue. ***
Comment 4 Jaroslav Tulach 2009-08-10 08:19:42 UTC
Will be integrated on Wednesday, Aug 12, 2009:
http://www.netbeans.org/nonav/issues/showattachment.cgi/85866/X.diff
Comment 5 Jaroslav Tulach 2009-08-12 09:59:06 UTC
ergonomics#029ce979847c
Comment 6 Quality Engineering 2009-08-13 06:05:55 UTC
Integrated into 'main-golden', will be available in build *200908130201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/029ce979847c
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #162780: Using 'fallback' layers to make templates available even if parts of a cluster are on
Comment 7 Tomas Pavek 2009-10-22 16:44:26 UTC
*** Issue 175148 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo