Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 162764 - Cannot globally modify action mappings for default project actions.
Cannot globally modify action mappings for default project actions.
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 21:17 UTC by Jesse Glick
Modified: 2012-04-13 16:40 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-04-15 21:17:33 UTC
I clicked this button in Maven options and added

Action: build
Execute Goals: install
Set Properties: maven.test.skip=true

with the intention that F11 would skip tests (while S-F11 would still do a clean build incl. tests). But it seems to
have no effect; when I press F11 on hudson/trunk/main/core, I still see

NetBeans: Executing 'mvn -Dnetbeans.execution=true install'

and tests are run.

Of course I could customize this action for this project, but I would rather this change apply to all projects, and
anyway I do not want an nbactions.xml in the source tree.
Comment 1 Milos Kleint 2009-04-16 07:10:18 UTC
in a way it works as intended, it only allows adding and changing non-default action mappings. That's what "custom"
stands for. These actions appear in the "Custom" popup submenu.

The problem is that the default files with actions are distributed in multiple modules and need to merged. Previously
we've done some complex transformations on the files, i've refactored that out, but I'm still missing a
"mimelookup"-like registration that would allow easy merging of the various definitions. Once that is done, the UI for
it can be written as well. 

While I'd love to do it for 6.7, I'm almost sure I won't have enough time for it. -> next
Comment 2 Jesse Glick 2009-05-18 14:37:31 UTC
I recently found that there is a checkbox allowing you to skip tests on non-test-specific actions, which is exactly what
I wanted. So I would no longer personally use this feature, I think.
Comment 3 jpleed3 2009-12-30 09:54:46 UTC
It would be helpful if nbactions.xml and nb-configuration.xml acted in the same manner as a parent POM: if I have a nbaction.xml in a parent project then all actions are inherited.

The ability to set global options on the default actions would be equally helpful. I could write custom actions to do what I want, but then I can't use the keyboard shortcuts.
Comment 4 Antonin Nebuzelsky 2010-07-30 15:17:11 UTC
Reassigning to default owner.
Comment 5 Jesse Glick 2010-09-24 13:56:34 UTC
(In reply to comment #2)
> I would no longer personally use this feature

Not a P2.

(In reply to comment #3)
> It would be helpful if nbactions.xml and nb-configuration.xml acted in the same
> manner as a parent POM: if I have a nbaction.xml in a parent project then all
> actions are inherited.

Probably impractical, since POM-based inheritance relies on release POMs being installed into the repository. The content of these files could be optionally, or always, folded into pom.xml in a special NetBeans section, provided that it was meant to be sharable (otherwise it probably needs to be kept in the userdir, since profiles.xml is no longer read in M3).
Comment 6 Milos Kleint 2012-04-13 06:57:21 UTC
maybe we could pinpoint some generic actions like "Build", "Clean" "Build with dependencies"?
Comment 7 Jesse Glick 2012-04-13 16:40:57 UTC
Probably this is not worth working on. A fix of bug #153420 would be more generally useful.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo