Bug 16270 - IDE hanged up after popup invocation from editor
IDE hanged up after popup invocation from editor
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
3.x
All All
: P1 (vote)
: 3.x
Assigned To: issues@debugger
issues@debugger
:
: 15915 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-05 11:32 UTC by Petr Slegr
Modified: 2003-06-30 17:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (4.71 KB, text/plain)
2001-10-05 11:33 UTC, Petr Slegr
Details
complete thread dump (22.96 KB, text/plain)
2001-10-05 14:17 UTC, Petr Slegr
Details
Thread dump from Solaris (199.25 KB, text/plain)
2001-10-05 14:38 UTC, David Kaspar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Slegr 2001-10-05 11:32:50 UTC
[dev-20011005]

IDE hanged up (consumed 100% of time) after popup invocation from editor.

Not reproducible now.

What I did:
1. Invoke Internationalization|Internationalize action on 
examples/advanced/MemoryView.form (results in opening of this form).
2. Open examples/texteditor/About.form and go to its editor pane.
3. There I tried to invoke popup menu.

The fragment of stacktrace is attached.
Comment 1 Petr Slegr 2001-10-05 11:33:48 UTC
Created attachment 2859 [details]
thread dump
Comment 2 Petr Slegr 2001-10-05 14:13:59 UTC
It happened next two times for me - when working with debugger.

Complete thread dump (however long) is available.
Comment 3 Petr Slegr 2001-10-05 14:17:19 UTC
Created attachment 2870 [details]
complete thread dump
Comment 4 David Konecny 2001-10-05 14:23:01 UTC
Looks like debugger problem.
Comment 5 David Kaspar 2001-10-05 14:33:39 UTC
It happens on Solaris also when I've done these action:
Create Java file:
public class Main () {
public static void main (String[] str) {
System.out.println ("AA");
}
}Press F4 on line with System.out....
Press F7 for step into println method
Comment 6 David Kaspar 2001-10-05 14:38:08 UTC
Created attachment 2873 [details]
Thread dump from Solaris
Comment 7 Miloslav Metelka 2001-10-05 18:54:23 UTC
It happens every time if you have a running debugger and stop over a
variable. Tooltip evaluation is then invoked which asks registered
tooltip annotations (currently only debugger) to return tooltip text.
Looks like the debugger tooltip annotation evaluates the result and it
fires property change, but it does not remember the returned value
once the getShortDescription() is called again and initiates the
computation again which causes infinite loop. The tooltip support was
previously calling Annotation.getShortDescription() in the
propertyChange() body to get the current value of the description text
(to cover the case when somebody would only fire(prop, null, null))
but to avoid things like this I will assume that valid value will be
always fired and only get the text by using evt.getNewValue().
Fixed in NbToolTip.
Comment 8 Jan Stola 2001-10-09 11:18:16 UTC
Verified in Netbeans build 20011009.
Comment 9 Miloslav Metelka 2001-10-11 16:50:29 UTC
*** Issue 15915 has been marked as a duplicate of this issue. ***
Comment 10 Quality Engineering 2003-06-30 17:28:53 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo