Bug 162588 - Opening project from Kenai takes a long time
Opening project from Kenai takes a long time
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 163871 164610 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 13:39 UTC by Jaromir Uhrik
Modified: 2009-05-07 07:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
patch suggested by Jarda, for API review (6.31 KB, text/plain)
2009-04-24 15:52 UTC, Tomas Pavek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2009-04-14 13:39:11 UTC
Product Version: NetBeans IDE Dev (Build 200904140201)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

Steps to reproduce:
-start full ide with clear userdir (do not create any project!)
-log in to Kenai (main menu Team| Kenai| Login to Kenai...)
-open some Kenai project which has sources available (e.g. "fileman")
-expand the Sources node of this project and push "get" in the subnode
-push "Get From Kenai" button
-once the Checkout Completed dialog appears ->  click on "Open Project" button

-->> no progress appears and IDE looks like nothing is happening for ~10 seconds. Some feedback to user needs to be
provided - probably the progress API should show the progress that some plugins are turning on. Seems like the problem
of ergonomics because if I repeat steps while the Java support is on then it is smooth (no time is needed for java
support modules loading).
Comment 1 Tomas Pavek 2009-04-24 15:52:20 UTC
Created attachment 80866 [details]
patch suggested by Jarda, for API review
Comment 2 Ondrej Vrabec 2009-04-27 12:56:22 UTC
Patch works. Please review the API change.
Comment 3 Ondrej Vrabec 2009-04-30 08:45:43 UTC
*** Issue 163871 has been marked as a duplicate of this issue. ***
Comment 4 Ondrej Vrabec 2009-05-06 08:53:24 UTC
fixing: cdev #e8451ed3f7b0
Comment 5 Tomas Pavek 2009-05-06 17:37:11 UTC
*** Issue 164610 has been marked as a duplicate of this issue. ***
Comment 6 Quality Engineering 2009-05-07 07:54:48 UTC
Integrated into 'main-golden', will be available in build *200905070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e8451ed3f7b0
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #162588 - Opening project from Kenai takes a long time
OpenProjects.open() supports visual progress


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo