Bug 162566 - java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry
java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.n...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM, THREAD
: 159264 162352 162535 162723 (view as bug list)
Depends on:
Blocks: 159586
  Show dependency treegraph
 
Reported: 2009-04-14 10:10 UTC by Jiri Prox
Modified: 2009-07-01 11:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.32 KB, text/plain)
2009-04-14 10:11 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2009-04-14 10:10:52 UTC
Build: NetBeans IDE Dev (Build 200904131401)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-132, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-275
OS: Mac OS X, 10.4.11, i386

User Comments:
GUEST: starting NetBeans

zorro2b: Opening a Maven project

GUEST: Started the IDE for the first time (settings imported from 6.5, including a few maven projects).

jiriprox: CME occured on IDE startup



Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.HashMap$HashIterator.nextEntry(HashMap.java:841)
        at java.util.HashMap$EntryIterator.next(HashMap.java:883)
        at java.util.HashMap$EntryIterator.next(HashMap.java:881)
        at org.netbeans.core.startup.NbInstaller.shouldDelegateClasspathResource(NbInstaller.java:842)
        at org.netbeans.ModuleManager$SystemClassLoader.shouldDelegateResource(ModuleManager.java:470)
        at org.netbeans.ProxyClassLoader.getResource(ProxyClassLoader.java:350)
Comment 1 Jiri Prox 2009-04-14 10:11:01 UTC
Created attachment 80026 [details]
stacktrace
Comment 2 Jiri Skrivanek 2009-04-14 11:05:29 UTC
Jesse, could you look at it? You did changes in NbInstaller related to issue 159586. There is many
ConcurrentModificationException exceptions reported in last days. They are thrown while starting IDE and importing
settings from NB6.5. See issue 161812, #162352, #162504, #162535.
Comment 3 Jiri Skrivanek 2009-04-14 11:06:16 UTC
*** Issue 162352 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2009-04-14 18:24:21 UTC
Looks like a simple lack of synchronization. core-main #9e38b685f441
Comment 5 Jiri Skrivanek 2009-04-15 08:55:05 UTC
*** Issue 162535 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Skrivanek 2009-04-15 14:55:57 UTC
*** Issue 162723 has been marked as a duplicate of this issue. ***
Comment 7 Quality Engineering 2009-04-15 19:31:00 UTC
Integrated into 'main-golden', will be available in build *200904151401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9e38b685f441
User: Jesse Glick <jglick@netbeans.org>
Log: #162566: CME.
Comment 8 Jesse Glick 2009-04-20 14:55:47 UTC
*** Issue 159264 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo