Bug 162538 - [67cat] Unit Test code coverage for NB 6.7
[67cat] Unit Test code coverage for NB 6.7
Status: RESOLVED WONTFIX
Product: contrib
Classification: Unclassified
Component: Codecoverage
6.x
All All
: P1 (vote)
: TBD
Assigned To: Martin Schovanek
issues@contrib
:
Depends on: 163397 163398 163668
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 20:25 UTC by theshadow27
Modified: 2013-04-16 00:47 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description theshadow27 2009-04-13 20:25:52 UTC
The Code Coverage module (http://codecoverage.netbeans.org/) for 5.5/6.0 worked fairly well, but it is not compatible with 6.7. Coverage is an integral 
aspect of unit testing, and it should be integrated into the JUnit module. 

Functional requirements:

1) Report percent of code executed by JUnit tests
2) Highlight code executed during JUnit tests
3) Provide a "hint" to make a JUnit test for a method that is not currently tested
Comment 1 Marian Mirilovic 2009-04-14 08:27:47 UTC
Hi Jacob, 
could you please report case #3 separately against junit? Thanks in advance.
Comment 2 theshadow27 2009-04-14 14:38:27 UTC
Number (3) Has been replaced by http://www.netbeans.org/issues/show_bug.cgi?id=162593 
Comment 3 theshadow27 2009-04-18 06:54:47 UTC
If there is anything I can do to help test progress with this please let me know! theshadow27 (at) gmail
Comment 4 Marian Mirilovic 2009-04-18 21:23:48 UTC
theshadow27, thanks for your offer. 
We are working on porting this module to 6.7  + we'll fix all P1s, let you know once it's ready for testing. Once again
thanks for your patience and offer to help.
Comment 5 Martin Schovanek 2009-04-21 13:14:09 UTC
Now available on Beta Update Center. theshadow27 can you please test it. BTW are you able to reproduce issue #131191 ?
There is lot of duplicates but I am not able to reproduce.
Comment 6 theshadow27 2009-04-22 04:04:47 UTC
PMI but where is the beta upgrade center? I don't see it if it is in 
http://deadlock.netbeans.org/hudson/job/javadoc-nbms/lastSuccessfulBuild/artifact/nbbuild/nbms/updates.xml.gz
Thanks.
Comment 7 Martin Schovanek 2009-04-22 11:16:03 UTC
It will be visible in Nb 6.7 Beta builds. Meanwhile you can try this URL:
http://updates.netbeans.org/netbeans/updates/6.7/uc/beta/beta/catalog.xml.gz

Not all modules here have to work wit Dev builds but codecoverage should.
Comment 8 theshadow27 2009-04-22 14:36:10 UTC
Evaluating. Not complete, will file reports as things arise. 
Comment 9 wesami 2009-08-13 10:57:36 UTC
Hi All,

Is this issue going to be resolved at all? 6.7 Code Coverage for Java is not working. How can you develop java without
testing? without properly working code coverage? it is really important. My team is resisting moving to netbeans from
Eclipse quoting lack (or thereof) of basic developer needs, like code coverage!

please help!
Sam
Comment 10 theshadow27 2009-09-02 12:15:14 UTC
@wesami - What is not working - Can you file specific issues? As of 6.7RC3, the codecoverage plugin was working (unpolished, but functional). There's 
always room for improvement, but they need bug/enhancement reports to do so. Thanks!
Comment 11 theshadow27 2010-04-18 17:36:15 UTC
Hi - This plugin will not install in 6.9 (fresh nightly). Thanks
Comment 12 Jesse Glick 2010-04-19 22:44:33 UTC
Version field is the earliest version to which the bug is known to apply.
Comment 13 theshadow27 2013-04-16 00:47:32 UTC
The 6.7 beta code coverage plugin is no longer being maintained


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo