Bug 162530 - [67cat] com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'timewhale_dev.users' doesn't exist
[67cat] com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'timewhale...
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 7.0.1
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 173956 195404 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 18:39 UTC by hjuskewycz
Modified: 2011-03-30 13:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.06 KB, text/plain)
2009-04-13 18:39 UTC, hjuskewycz
Details
stacktrace (4.71 KB, text/plain)
2011-02-13 02:28 UTC, schkovich
Details
stacktrace (4.71 KB, text/plain)
2011-02-13 02:31 UTC, schkovich
Details
stacktrace (4.71 KB, text/plain)
2011-03-15 09:55 UTC, _ pandajava
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hjuskewycz 2009-04-13 18:39:44 UTC
Build: NetBeans IDE Dev (Build 200904011705)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments:
GUEST: Following the Connecting to a MySQL Database tutorial (IDE 6.0 against IDE 6.5 beta); found a number of items that did not match. New interface was definitely easier than the tutorial steps. I was following the "Running an SQL Script" section of the tutorial. The first delete went fine, but when I deleted the subject table, it provoked the MySQLSyntaxException error. The UI shows the table removed from the Tables node.

atellezflores: I have a store procedure that creates a temporary table (conalepsie.regpermisos), and after it finishes all processes drops that temporary table, inside MySQL QueryBrowser, no problems are reported by the tool, nor in Minq DBVisualizer



Stacktrace: 
org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbeans.modules.db.metadata.model.api.MetadataException: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'timewhale_dev.users' doesn't exist
        at org.netbeans.modules.db.metadata.model.JDBCConnMetadataModel.runReadAction(JDBCConnMetadataModel.java:99)
        at org.netbeans.modules.db.metadata.model.api.MetadataModel.runReadAction(MetadataModel.java:89)
        at org.netbeans.modules.db.explorer.node.ColumnNode.setupNames(ColumnNode.java:122)
        at org.netbeans.modules.db.explorer.node.ColumnNode.refresh(ColumnNode.java:109)
        at org.netbeans.api.db.explorer.node.NodeProvider.refresh(NodeProvider.java:133)
        at org.netbeans.modules.db.explorer.node.NodeRegistry.refresh(NodeRegistry.java:136)
Comment 1 hjuskewycz 2009-04-13 18:39:50 UTC
Created attachment 79999 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-07-01 07:44:33 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 3 Jiri Rechtacek 2010-11-25 10:24:06 UTC
*** Bug 173956 has been marked as a duplicate of this bug. ***
Comment 4 schkovich 2011-02-13 02:28:19 UTC
Created attachment 105949 [details]
stacktrace

Product Version: NetBeans IDE 7.0 Beta 2 (Build 201102111519)
Java: 1.6.0_22; Java HotSpot(TM) 64-Bit Server VM 17.1-b03
System: Linux version 2.6.35-25-generic running on amd64; UTF-8; en_US (nb)

During testing beta 2, while executing the task ysql_010, when executing the third command Create database, the exception was thown.

ysql_010
1. Rightclick "Databases" node and choose "Register MySQL Server".
2. Specify valid basic properties for MySQL server, but with user, who hasn't admin privilegies, and click "OK".
3. Rightclick MySQL server node and choose "Create Database...".
4. Choose database "sample" and click OK.
Expcected:
Message that user aren't granted should appear.
Actual:
Exception thrown
Comment 5 schkovich 2011-02-13 02:31:16 UTC
Created attachment 105950 [details]
stacktrace

Databases Integration Test Specification
http://qa.netbeans.org/modules/webapps/promo-h/DBIntegration.html

work_mysql_010

Create standard DB with user, who hasn't admin privilegies

1. Rightclick "Databases" node and choose "Register MySQL Server".
2. Specify valid basic properties for MySQL server, but with user, who hasn't admin privilegies, and click "OK".
3. Rightclick MySQL server node and choose "Create Database...".
4. Choose database "sample" and click OK.

Expected: Message that user aren't granted should appear.
Actuall: At step 3. exception is thrown
Comment 6 _ pandajava 2011-03-15 09:55:05 UTC
Created attachment 107015 [details]
stacktrace

When trying to create a new database with a user without admin privileges.
Based uppon test specification below : 
1. Rightclick "Databases" node and choose "Register MySQL Server".
2. Specify valid basic properties for MySQL server, but with user, who hasn't admin privilegies, and click "OK".
3. Rightclick MySQL server node and choose "Create Database...".
4. Choose database "sample" and click OK.
Comment 7 Jiri Rechtacek 2011-03-28 13:08:17 UTC
Still reproducible in NB7.0RC1. MySQL Registration dialog asks for user who has the administrator role, but IDE should be robust enough to handle this scenario.
Comment 8 Jiri Rechtacek 2011-03-29 15:48:45 UTC
core-main/rev/e1273293cbbb
Comment 9 Quality Engineering 2011-03-30 08:42:10 UTC
Integrated into 'main-golden', will be available in build *201103300400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e1273293cbbb
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #162530: [67cat] com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'timewhale_dev.users' doesn't exist
Comment 10 Jiri Rechtacek 2011-03-30 13:12:32 UTC
*** Bug 195404 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo