Bug 162353 - [67cat] [tools] Glassfish-V3 should be enabled with Ruby on Rails modules
[67cat] [tools] Glassfish-V3 should be enabled with Ruby on Rails modules
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@serverplugins
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 23:03 UTC by esmithbss
Modified: 2009-04-10 15:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Glassfish V3 is available (85.21 KB, image/png)
2009-04-10 13:51 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-04-09 23:03:40 UTC
[ BUILD # : 200904091401 ]
[ JDK VERSION : 1.6.* ]

When installing the Full version of the IDE, if you enable Ruby On
Rails, you should automatically enable Glassfish-V3-Prelude if it is
installed.

Currently, only the WEBrick server is available under a default
install prior to creating or opening a Java EE or Web Service
application.
Comment 1 esmithbss 2009-04-09 23:30:36 UTC
It appears that this may be a refresh issue.

If you try to create a RoR application out of the gate, the only server available is WEBrick.  But if you go to the
Services tab and expand the Servers tab, the Glassfish-V3-prelude server is found and is subsequently available.
Comment 2 Erno Mononen 2009-04-10 06:26:59 UTC
We probably don't want to complicate discovering v3 like that => P2.
Comment 3 Vince Kraemer 2009-04-10 07:43:33 UTC
It sounds like the glassfish.jruby module is not initializing correctly when the Ruby functionality is started.  I
should be able to fix that pretty quickly... or it will need to get attention from Jarda.
Comment 4 Jaroslav Tulach 2009-04-10 13:51:53 UTC
Created attachment 79887 [details]
Glassfish V3 is available
Comment 5 Jaroslav Tulach 2009-04-10 13:54:44 UTC
In my latest build (ergonomics#04d05628cb02) I did:

New Project -> Ruby on Rails -> Finish.
Tools/Servers

and Glassfish V3 is ready and available for use. 

All known exact steps to reproduce this problem seem to work -> marking fixed.
Comment 6 Erno Mononen 2009-04-10 15:17:03 UTC
Jardo, I think the issue is that v3 is not available when creating the project. There is a combo box for servers in the 
Rails project wizard, v3 should be listed there as one of the choices.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo