Bug 162274 - Cannot add most JavaEE servers
Cannot add most JavaEE servers
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@serverplugins
: ERGONOMICS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 08:55 UTC by Petr Jiricka
Modified: 2009-04-11 19:07 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The patch that I'd like to apply soon (29.17 KB, patch)
2009-04-10 13:45 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-04-09 08:55:31 UTC
Using a build from the web-main builder: http://bertram.netbeans.org/hudson/job/web-main/

1. Start a fresh build
2. Go to Services tab
3. On the Servers menu, choose Add Server...

=> The list only contains GlassFish v3 Prelude, but no other servers. This makes the situation worse than before,
because now when the Servers node is present by default, the user is lead to believe that it can be used. But it can't.
Comment 1 Petr Jiricka 2009-04-09 08:57:23 UTC
The workaround is to go to go to the New Web Project wizard, press Next to go to the second panel, and then press
Cancel. After this, all items are visible in the Add Server dialog.
Comment 2 Petr Jiricka 2009-04-09 09:03:24 UTC
Ergonomics-related, works fine without ergonomics.
Comment 3 Jaroslav Tulach 2009-04-10 12:38:52 UTC
I want to fix this problem by enhancing the dialog when no server is available.
Comment 4 Jaroslav Tulach 2009-04-10 13:20:27 UTC
This is the current dialog:
http://www.netbeans.org/nonav/issues/showattachment.cgi/79877/dlg-now.png
and this is the version that I propose to show:
http://www.netbeans.org/nonav/issues/showattachment.cgi/79882/dlg-future.png
in case we are in ergonomics mode, no server plugin is enabled yet, but we know there are available.

Petr H. mentioned yesterday that it might be better to embed this new dialog into the subsequent wizard. But that 
would require more richer API between the server module and the providers of the messages. We can think about 
improving the behaviour in future, but for beta I'd rather apply this simplistic solution. Which is not looking bad at 
all, imho.
Comment 5 Jaroslav Tulach 2009-04-10 13:45:34 UTC
Created attachment 79885 [details]
The patch that I'd like to apply soon
Comment 6 Vince Kraemer 2009-04-10 17:51:32 UTC
1. I would like to see check boxes instead of radio buttons in the 'dlg-future'.  I don't see a reason to prevent a user
from activating both clusters/plugins/whatever in a single operation.

2. What will happen if I activate one 'usage'... and then realize I want to activate the 'other' usage?  I think some
users will get stuck... they will:

1. start the IDE,
2. activate a usage via this new dialog
3. experiment with those kinds of projects
4. decide they want to try the other kinds of projects
5. end up stuck, since they cannot get that handy activate these servers dialog to appear again...

BTW: I honestly do not think that the proposed changes really address the issue as originally presented.  I think the
filer's initial expectation could be summarized as follows:

After I download and install the NB 6.7 bundle that includes server run-times and install that bundle, including the
server run-times, I expect to see the servers registered and 'ready to start' (or whatever), immediately after I start
the freshly installed IDE.

I think these changes will lead the user to a place where they are not completely lost, though...  There is an action
that they can take to get to the state they initially expected to be in, without having to switch to a completely
different center of focus (dialog/view/etc.) and return to their current center of focus.
Comment 7 Jaroslav Tulach 2009-04-10 19:46:02 UTC
Re. "checkboxes" - not possible for beta, needs yet unknown API contract.
Re. "use case" - imho already solved in issue 161664
Btw. "big picture" - we are also working on Welcome screen redesign which will make all "Server node" issues far less 
outstanding.

As far as I understand all the comments (here and in emails): So far we all think the
http://www.netbeans.org/nonav/issues/showattachment.cgi/79882/dlg-future.png
solution is better than current state. I see that as the most important impulse, as this is P1 bug.
Comment 8 Vince Kraemer 2009-04-10 22:48:54 UTC
fair enough
Comment 9 Jaroslav Tulach 2009-04-11 05:37:25 UTC
ergonomics#062b3fc6e188
Comment 10 Quality Engineering 2009-04-11 19:07:22 UTC
Integrated into 'main-golden', will be available in build *200904111401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/04d05628cb02
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: Proposed fix for #162274. Looks OK, but was not reviewed yet by Petr and Petr (phejl and pjiricka).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo