Bug 162256 - Profiling menu not visible after enabling Ruby
Profiling menu not visible after enabling Ruby
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@profiler
: ERGONOMICS
: 161490 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 20:33 UTC by esmithbss
Modified: 2009-04-17 08:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen Capture of newly installed IDE with a JRuby based Rails app loaded. -- Note No Profiler capabillities. (120.71 KB, text/plain)
2009-04-08 20:34 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-04-08 20:33:31 UTC
[ BUILD # : 200904051400 ]
[ JDK VERSION : 1.6.* ]

In order to profile a Ruby On Rails application which uses the
Built-in JRuby platform (which uses Java), the Java Profiler module
needs to be enabled.

By default, the Ruby system does not have the Java system or the Java
Profiler enabled and does not provide any means of profiling the
application.
Comment 1 esmithbss 2009-04-08 20:34:22 UTC
Created attachment 79772 [details]
Screen Capture of newly installed IDE with a JRuby based Rails app loaded. -- Note No Profiler capabillities.
Comment 2 esmithbss 2009-04-08 20:36:45 UTC
See NetCat 6.7 archives (subject Re: Default Plugins for Ruby on Rails projects) for additional details.
Comment 3 Jiri Kovalsky 2009-04-09 10:29:56 UTC
The thread is available here: http://www.nabble.com/-67cat--Default-Plugins-for-Ruby-on-Rails-projects-to22932316.html
Comment 4 Jaroslav Tulach 2009-04-10 14:20:51 UTC
Finally we know what the problem is:
http://www.nabble.com/forum/ViewPost.jtp?post=22974222

The Profile menu disappears after enabling JRuby in the full IDE (with 
ergonomics). It should be there by design and is there before the JRuby 
plugins are enabled.

From Erik's last post it's also clear that the wanted action is Attach Profiler, 
knowing that starting JRuby app via Profiler is not possible - that's another 
issue. 
Comment 5 Jaroslav Tulach 2009-04-10 15:16:34 UTC
*** Issue 161490 has been marked as a duplicate of this issue. ***
Comment 6 Jaroslav Tulach 2009-04-16 19:09:52 UTC
ergonomics#a02098c105d8
Comment 7 Quality Engineering 2009-04-17 08:38:41 UTC
Integrated into 'main-golden', will be available in build *200904170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a02098c105d8
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #162256: Static analysis of Menu/Profile


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo