Bug 16222 - Change of utilities module (dev -> pilsen)
Change of utilities module (dev -> pilsen)
Status: CLOSED FIXED
Product: utilities
Classification: Unclassified
Component: Search
3.x
PC Linux
: P1 (vote)
: 3.x
Assigned To: Peter Zavadsky
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-04 10:33 UTC by Marek Grummich
Modified: 2003-07-01 15:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Exception (3.22 KB, text/plain)
2001-10-04 10:34 UTC, Marek Grummich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Grummich 2001-10-04 10:33:53 UTC
Build 200110030100
Jdk 1.3.1
How to reproduce:
1. Uninstall a utilities module 
2. Use AutoUpdate for installation of utilities module from Pilsen
3. During restart of IDE two error window are displayed
   "org/openidex/search/SearchEngine", "org/openidex/search/DetailCookie" and an 
   attached exception is thrown.
Comment 1 Marek Grummich 2001-10-04 10:34:40 UTC
Created attachment 2843 [details]
Exception
Comment 2 _ ttran 2001-10-05 08:01:15 UTC
Utilities depends on openidex.  There is no commitment to keep
backward compatibility of openidex.  The error in openidex is it
hasn't raise the major version number (OpenIDE-Module:
org.openidex.util/1) to indicate it broke backward compat.
Comment 3 _ ttran 2001-10-05 08:27:26 UTC
If we raise the major version number from /1 to /2 we must notify
nbdev and fix the manifests of all modules which depend on openidex
(there are a lot of them :-(
Comment 4 Peter Zavadsky 2001-10-09 13:02:38 UTC
Fixed in [main-trunk].
Comment 5 Marek Grummich 2002-10-14 11:25:17 UTC
Verified
Comment 6 Quality Engineering 2003-07-01 15:52:34 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo