Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 162016 - [67cat] NullPointerException at org.netbeans.modules.java.source.indexing.JavaParsingContext.<init>
[67cat] NullPointerException at org.netbeans.modules.java.source.indexing.Jav...
Status: RESOLVED DUPLICATE of bug 160174
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 (vote)
: TBD
Assigned To: Rastislav Komara
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 08:37 UTC by neilg
Modified: 2009-04-07 15:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.08 KB, text/plain)
2009-04-06 08:37 UTC, neilg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neilg 2009-04-06 08:37:45 UTC
Build: NetBeans IDE Dev (Build 200904030200)
VM: OpenJDK 64-Bit Server VM, 14.0-b08, OpenJDK Runtime Environment, 1.6.0_0-b14
OS: Linux, 2.6.28-11-generic, amd64

User Comments:
neilg: Closing IDE

tboudreau: Exception occurred when I clicked the main window's close button to shut down the IDE while classpath scanning was occuring.



Stacktrace: 
java.io.IOException
        at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:472)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1.run(JavaCustomIndexer.java:117)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1.run(JavaCustomIndexer.java:115)
        at org.netbeans.modules.java.source.usages.ClassIndexManager.writeLock(ClassIndexManager.java:100)
        at org.netbeans.modules.java.source.indexing.JavaCustomIndexer.index(JavaCustomIndexer.java:115)
        at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor.index(Indexable.java:141)
Comment 1 neilg 2009-04-06 08:37:50 UTC
Created attachment 79505 [details]
stacktrace
Comment 2 Jiri Prox 2009-04-07 15:46:43 UTC

*** This issue has been marked as a duplicate of 160174 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo