Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 161795 - [67cat] refactoring code (Encapsulate Fields) disbled
[67cat] refactoring code (Encapsulate Fields) disbled
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
: RANDOM
: 162519 162815 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 17:37 UTC by vladimircs
Modified: 2009-04-16 19:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screen trying to encapsulate (111.99 KB, text/plain)
2009-04-02 17:41 UTC, vladimircs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vladimircs 2009-04-02 17:37:00 UTC
[ BUILD # : 200904011705 ]
[ JDK VERSION : 1.6.* ]

Product Version: NetBeans IDE Dev (Build 200904011705)
Java: "1.6.0_10"
Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot(TM) Server VM (build 11.0-b15, mixed mode)

System: Linux version 2.6.24-23-server running on i386;
LANG=es_BO.UTF-8


Refactorings are disabled in java source code editor.

Steps to reproduce:
1) start full IDE (not user fresh test)
2) start new java application 
3) write vars in the class
4) right click and select Refactor. 
-> Encapsulta fields are disabled

	
The same problem is when you open an existing project.
Comment 1 vladimircs 2009-04-02 17:41:33 UTC
Created attachment 79304 [details]
screen trying to encapsulate
Comment 2 dancehands 2009-04-02 21:58:05 UTC
I am working on PHP projects and I find this issue happens sporadically as well. For example, I've been editing PHP
files all day today and for the first several hours I was able to refactor to rename variables within a class method.
Now, an hour or so later since I last tried and it worked, the refactor menu items are now disabled and I can't refactor
a variable anymore.

I've actually noticed this problem over the last 4-5 builds that I've been testing for the last 2 weeks. Not sure if the
problem existed before that, but I don't recall this ever being a problem in nb 6.5.

Product Version: NetBeans IDE Dev (Build 200903310200)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 3 David Strupl 2009-04-03 13:59:45 UTC
This is not P1 issue IMHO.
Comment 4 Jan Pokorsky 2009-04-06 12:15:03 UTC
I am not able to reproduce it with netbeans-trunk-nightly-200904020200 but with my build 090401. I will investigate.
Comment 5 Jan Pokorsky 2009-04-07 15:57:57 UTC
fixed as http://hg.netbeans.org/jet-main/rev/f49306ff0fba
Comment 6 Quality Engineering 2009-04-09 19:23:23 UTC
Integrated into 'main-golden', will be available in build *200904091401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f49306ff0fba
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #161795: update menu items to reflect their Action.isEnabled when synchronizing refactoring menu
Comment 7 Jan Pokorsky 2009-04-14 13:25:12 UTC
*** Issue 162519 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2009-04-15 16:28:12 UTC
reproducible in NB Dev (200904140200)
Comment 9 Jan Pokorsky 2009-04-15 17:50:43 UTC
I can reproduce it only with the context menu. As a workaround it should help to open the Refactoring main menu to
refresh actions. I will have a look at it.
Comment 10 Jan Pokorsky 2009-04-15 19:45:02 UTC
fixed as http://hg.netbeans.org/jet-main/rev/3aa4537ec166
Comment 11 Jiri Prox 2009-04-16 12:23:50 UTC
*** Issue 162815 has been marked as a duplicate of this issue. ***
Comment 12 Quality Engineering 2009-04-16 19:20:16 UTC
Integrated into 'main-golden', will be available in build *200904161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3aa4537ec166
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #161795: update menu items to reflect their Action.isEnabled even for popup menu


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo