Bug 161691 - 170000 uigesture* files
170000 uigesture* files
Status: RESOLVED DUPLICATE of bug 228670
Product: ide
Classification: Unclassified
Component: Logger
6.x
All Windows XP
: P1 with 2 votes (vote)
: 7.4
Assigned To: Martin Entlicher
logger-issues@ide
:
: 162777 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 17:15 UTC by vladakk
Modified: 2013-10-02 09:12 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vladakk 2009-04-01 17:15:01 UTC
I must say, NB uigestures subcomponent is like any Windows Virus program !!!

Last time, on my bad 3G internet connection,
uigestures made about 170000 uigesture* files,
without any notification !!!

Somebody should fix that.
Comment 1 mslama 2009-04-01 18:44:42 UTC
What are names of uigestures files? There should be only 'uigestures' and eventually 'uigestures.1'.
Comment 2 mslama 2009-04-01 18:46:16 UTC
These files are in NB userdir in folder var/log.
Comment 3 vladakk 2009-04-01 19:02:52 UTC
No, in /tmp

All starts with prefix uigesture and ends with .html


Only way to remove them is to partially delete with rm command:
rm uigesture1* 
rm uigesture2*
...

from 1 to 9
Comment 4 mslama 2009-04-02 13:41:25 UTC
Usual pattern is:
File tmp = File.createTempFile("uigesture", ".html");
tmp.deleteOnExit();

According to javadoc this file should be deleted when JVM exits normally. We had so far no such report. This is so long
time. When IDE tries to upload uigesture data it creates this file. I do not see any way how IDE could create so many
files and then did not delete them. If you are able to reproduce it I can send you uihandler module with some logging to
see what happens.
Comment 5 mslama 2009-04-02 14:23:54 UTC
Have you set automatic submit? Please check content of
$NBUSERDIR/config/Preferences/org/netbeans/modules/uihandler.properties namely property autoSubmitWhenFull. If it was
set to true and upload fails it could try to upload more often so it might lead to more temp files. But again these
should be deleted on exit. Can you check IDE log (messages.log) if there is any error about failed upload?
Comment 6 junminh 2009-04-06 20:30:44 UTC
i can confirm this "virus"!!.... 

http://i42.tinypic.com/de20zq.png
Comment 7 mslama 2009-04-08 11:46:47 UTC
I just found when I wanted to commit patch that it was already fixed by jtulach on Jan 24 in trunk as
http://hg.netbeans.org/core-main/rev/68f80f0a7f99.
Comment 8 pgebauer 2009-04-08 14:23:35 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html
Comment 9 mslama 2009-04-28 11:00:16 UTC
*** Issue 162777 has been marked as a duplicate of this issue. ***
Comment 10 stjimmy111 2009-07-23 20:55:22 UTC
kan le ma puki..
wtf r u guys at netbeans thinking?! 
this issue mentioned by mslama really fucked up my whole windows, i have to spend days to remove 300000++ uigesture files!!!
i thought u all are expert programmers, how can you all leave this file generation thing on an infinite loop?!
is this a sick joke?!
our jobs and college grades depends on this IDE!
Comment 11 vieiro 2009-08-19 09:09:31 UTC
This issue makes the whole *JDK* unusable in Windows and should be fixed ASAP.

My whole Windows XP box is slowed down by *tons* of uigesture files in %TMP%. jconsole and jps commands in the JDK
refuse to start up. NetBeans refuses to start up. Looking at the java process through strace [1] shows lots of calls to
FindNextFileW system function.

uigesture files are created every few seconds, and are not removed when NetBeans exists nor when the system shuts down.
For an example see some of the files created a few days ago (today is 19/08/2009, so these are six days old).

13/08/2009  16:31             1.957 uigesture8988786389391858513.html
13/08/2009  16:20             1.957 uigesture939032322918043642.html
13/08/2009  16:36             1.957 uigesture9124333499600756140.html
13/08/2009  16:24             1.957 uigesture8905050487427416529.html
13/08/2009  16:22             1.957 uigesture8995933474306236204.html
13/08/2009  16:24             1.957 uigesture9133144850353875939.html
13/08/2009  16:43             1.957 uigesture8894488660295469371.html
13/08/2009  16:23             1.957 uigesture8826992363862380294.html
13/08/2009  16:29             1.957 uigesture9145471983816754810.html
13/08/2009  16:30             1.957 uigesture9115363722408283406.html
13/08/2009  16:38             1.957 uigesture9140111593239979603.html
13/08/2009  16:22             1.957 uigesture8970576225065123731.html
13/08/2009  16:35             1.957 uigesture8894887073532110394.html
13/08/2009  16:23             1.957 uigesture9195503388871273732.html
13/08/2009  16:33             1.957 uigesture8964140880453659087.html
13/08/2009  16:46             1.957 uigesture8834537114239576011.html
13/08/2009  16:47             1.957 uigesture8873700590946122589.html
13/08/2009  16:51             1.957 uigesture8838573658539586090.html
13/08/2009  16:21             1.957 uigesture8924386166612539298.html
13/08/2009  16:17             1.957 uigesture9103207107781869667.html
13/08/2009  16:17             1.957 uigesture950046403118510523.html
13/08/2009  16:33             1.957 uigesture9019872881029379472.html
13/08/2009  16:32             1.957 uigesture9118337293313841306.html
13/08/2009  16:45             1.957 uigesture9150772866129042415.html
13/08/2009  16:38             1.957 uigesture8926194556687360495.html
13/08/2009  16:18             1.957 uigesture8976568941320324331.html
13/08/2009  16:44             1.957 uigesture8847641095483281899.html
13/08/2009  16:17             1.957 uigesture9148768316159348721.html
13/08/2009  16:33             1.957 uigesture8890186197810587932.html
13/08/2009  16:51             1.957 uigesture891977758797110127.html
13/08/2009  16:38             1.957 uigesture892919424071062906.html
13/08/2009  16:43             1.957 uigesture9136138500323650375.html
13/08/2009  16:18             1.957 uigesture925793205359887546.html
13/08/2009  16:36             1.957 uigesture9074707509843364815.html
13/08/2009  16:22             1.957 uigesture9172809064565219551.html
13/08/2009  16:17             1.957 uigesture898409975225099413.html
13/08/2009  16:29             1.957 uigesture8963011803623591732.html
13/08/2009  16:40             1.957 uigesture991447266512184439.html
13/08/2009  16:51             1.957 uigesture889899529805062568.html
13/08/2009  16:43             1.957 uigesture9142568257510554803.html
13/08/2009  16:22             1.957 uigesture9036942934439267242.html
13/08/2009  16:35             1.957 uigesture8810151785473428364.html
13/08/2009  16:31             1.957 uigesture9122396738290444813.html
13/08/2009  16:24             1.957 uigesture9012327660522445079.html
13/08/2009  16:28             1.957 uigesture916538989094546457.html
13/08/2009  16:42             1.957 uigesture971960260443922795.html
13/08/2009  16:30             1.957 uigesture8999106263553051776.html
13/08/2009  16:39             1.957 uigesture96897417491219623.html
13/08/2009  16:49             1.957 uigesture8872160782604625426.html
13/08/2009  16:52             1.957 uigesture8783988206937222535.html
13/08/2009  16:27             1.957 uigesture9062800599506916663.html
13/08/2009  16:19             1.957 uigesture9214307577639620613.html
13/08/2009  16:22             1.957 uigesture9039637267257100628.html
13/08/2009  16:38             1.957 uigesture8799568799285428228.html
13/08/2009  16:47             1.957 uigesture8882793304141247012.html
13/08/2009  16:29             1.957 uigesture949462830876898524.html


I'm changing this to "current" version (I'm seeing this in NB 6.5.1, though) and OS to "Windows XP". I assume this does
not happen on Unix boxes as "/tmp" is usually deleted when the system shuts down.

[1] - http://www.intellectualheaven.com/default.asp?BH=projects&H=strace.htm
Comment 12 mslama 2009-08-19 12:56:54 UTC
It is not fixed in 6.5.1. Also fix was not published in any patch for NB 6.5/6.5.1. TM is 6.7 so it is correct - it
means that it is fixed in NB 6.7.
Comment 13 vieiro 2009-08-19 13:11:14 UTC
Ok.
Comment 14 smdelfin 2009-12-07 00:57:43 UTC
I thought we had a virus. So I downloaded different types of free antiviruses, but we found nothing. So I downloaded different brands of anti-malwares, and again nothing was found. I checked our firewall, but it was ok.
Sadly, after everything, my last option was to reformat. Before I reformat, I found this bug, and I remembered that throughout my scanning of the harddisks for viruses and others, it took a very long time to scan these files. I never expected that these uigesture files were created by Netbeans.
I sympathize with the others who reported this bug, that it's really very annoying.
Comment 15 r0ck3r 2013-03-28 07:40:00 UTC
NetBeans version 7.3
Fedora 18

I also have this issue, but how I knew it's appear only then I have enabled Settings->"Send Anonym Data" (or so) and haven't Internet connection
Comment 16 dront78 2013-10-02 05:57:51 UTC
got this today's morning with 7.3.1
Comment 17 Martin Entlicher 2013-10-02 09:12:40 UTC
Fixed in 7.4.

*** This bug has been marked as a duplicate of bug 228670 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo