Bug 161664 - Installed Servers must be visible by default
Installed Servers must be visible by default
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@serverplugins
: ERGONOMICS, REGRESSION
: 161698 162063 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 12:41 UTC by Petr Jiricka
Modified: 2009-04-16 08:54 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Petře H. what do you think could the RootNode enable enterprise cluster when expanded and there are some servers? (2.06 KB, patch)
2009-04-03 14:51 UTC, Jaroslav Tulach
Details | Diff
Real patch with fix, test and usage of the API in JavaEE cluster. (9.15 KB, patch)
2009-04-06 15:01 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-04-01 12:41:52 UTC
1. Install a build from the installer, including the bundled servers (GF v2 and v3 Prelude)
2. Start this build with a fresh userdir
3. Go to Services tab - there is no Servers node. I expect to see the Servers node with the bundled servers registered
underneath.

The workaround is to create a new web project, which will make the Servers node visible, but this workaround is not
acceptable.
Comment 1 Petr Jiricka 2009-04-01 12:43:15 UTC
Reproduced using build 200903311400.
Comment 2 Jaroslav Tulach 2009-04-03 14:49:42 UTC
Servers node in now visible. Still that is not enough. We also need to make sure all the installed servers are visible 
under that node.
Comment 3 Jaroslav Tulach 2009-04-03 14:51:01 UTC
Created attachment 79396 [details]
Petře H. what do you think could the RootNode enable enterprise cluster when expanded and there are some servers?
Comment 4 Petr Jiricka 2009-04-03 15:17:04 UTC
> Servers node in now visible.

I don't see it in the latest build, presumably this change is not propagated yet. Are you referring to this change?
http://hg.netbeans.org/ergonomics/rev/bae89dd72ba8

I must say I don't think that's the right approach, because this will mean that the Servers node is visible also in the
C++, PHP and JavaSE distribution, which is not desirable. It should only be visible in All, Java and Ruby - same as in 6.5.
Comment 5 Jaroslav Tulach 2009-04-06 14:59:38 UTC
*** Issue 161698 has been marked as a duplicate of this issue. ***
Comment 6 Jaroslav Tulach 2009-04-06 15:01:23 UTC
Created attachment 79528 [details]
Real patch with fix, test and usage of the API in JavaEE cluster.
Comment 7 Jaroslav Tulach 2009-04-06 15:04:47 UTC
Petr, can you please review and integrate my patch? Also there seems to be some problem with listening to list of 
installed servers. As soon as I expand the node, the Java EE functionality is enabled, but no Tomcat or Glassfish V2 
is visible. I need to right click on the node and choose Add Server. Then the list of installed servers refreshes. Can 
you please fix this refresh problem and then mark this as fixed? Thanks.

Comment 8 Vince Kraemer 2009-04-06 20:42:53 UTC
Hi. It looks like this commit http://hg.netbeans.org/main-golden/rev/149aa862edd5 is a partial attempt to resolve this
issue.

Is that commit going to get rolled back, once this issue is resolved completely?

It seems like it is the root cause of issue 162063 and issue 162064.
Comment 9 Jaroslav Tulach 2009-04-07 08:14:47 UTC
*** Issue 162063 has been marked as a duplicate of this issue. ***
Comment 10 arungupta 2009-04-07 19:50:55 UTC
Just downloaded M3 and found the Servers node missing. I think this is really confusing, a poor design, and will require
multiple emails/service calls on the users alias. It's certainly breaks the seamless experience between GlassFish and
NetBeans.
Comment 11 Petr Hejl 2009-04-08 16:19:40 UTC
Fixed in web-main 877170f42056.

Jardo perhaps the action should go to j2eeserver or similar place (it is strange that there is tomcat related property
mentioned in layer of glassfish)?
Comment 12 Petr Jiricka 2009-04-09 09:08:20 UTC
I tried the build that contains the fix, and the behavior is still really broken. I filed issues 162273, 162274 and
162275 against the current behavior:
http://www.netbeans.org/issues/buglist.cgi?issue_id=162273,162274,162275 
Comment 13 Jaroslav Tulach 2009-04-09 12:21:44 UTC
I guess that now, when we have three issues instead of one, we can close the original.
Comment 14 Quality Engineering 2009-04-09 19:34:06 UTC
Integrated into 'main-golden', will be available in build *200904091401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/877170f42056
User: phejl@netbeans.org
Log: #161664 Installed Servers must be visible by default
Comment 15 Petr Jiricka 2009-04-16 08:54:26 UTC
I found one additional minor UI problem, which I filed as issue 162768.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo