Bug 161599 - [67cat] Project doesn't run anymore
[67cat] Project doesn't run anymore
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Project
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 15:27 UTC by ulfzibis
Modified: 2009-05-07 23:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Compile errors (38.81 KB, image/jpeg)
2009-03-31 15:28 UTC, ulfzibis
Details
leaded to wrong location of another version of this java file (40.01 KB, image/jpeg)
2009-03-31 15:29 UTC, ulfzibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2009-03-31 15:27:44 UTC
[ BUILD # : 6.7 M2 ]
[ JDK VERSION : 1.6.* ]

I installed NB 6.7 M2 and imported settings from my 6.5.
Then I opened copy of project, which run fine under NB 6.5, and got
compile errors (see Attachment). Run single test (here
java.nio.cs.CharsetsTest) didn't run either.

If I right-click->Goto Source on unknown item (here
ExtendedCharsets), I was leaded to wrong location of another version
of this java file.
Comment 1 ulfzibis 2009-03-31 15:28:58 UTC
Created attachment 79148 [details]
Compile errors
Comment 2 ulfzibis 2009-03-31 15:29:46 UTC
Created attachment 79150 [details]
leaded to wrong location of another version of this java file
Comment 3 ulfzibis 2009-03-31 15:34:42 UTC
Maybe you like to check out my project:
https://java-nio-charset-enhanced.dev.java.net/ (checkout Subversion revision=694)
To run from NetBeans 6.5, 2nd JDK must be installed (here: JDK 6u03).
Be aware to first Run make\src\build.tools.charsetmapping.GenerateCharsetData.java from configuration
"GenerateCharsetData", then Build again from "default" configuration, to move the generated files to "build" and "dist".
After you can run the test classes, e.g. CharsetsTest.java.
Comment 4 Milos Kleint 2009-03-31 17:00:11 UTC
j2se project type, reassigning for evaluation.
Comment 5 Dusan Balek 2009-04-01 09:39:36 UTC
Have you tried to start the IDE with the clean userdir?
Comment 6 ulfzibis 2009-04-01 10:38:03 UTC
Can userdir be cleaner as after fresh installation of IDE ?

I noticed, that files in nbproject folder have been modified automatically just after opening the project, which was
created by 6.0, and updated later by 6.1, 6.5. Maybe this is the cause for my problems.

Comment 7 Jan Jancura 2009-04-01 14:21:22 UTC
1) I can not build your project:
/x/java-nio-charset-enhanced/nbproject/build-impl.xml:386: The following error occurred while executing this line:
/x/java-nio-charset-enhanced/nbproject/build-impl.xml:201: srcdir "/x/java-nio-charset-enhanced/resources" does not exist!

looks like something missing in svn?

2) Run single test was renamed, use main menu/Run/Test File instead, please.
Comment 8 ulfzibis 2009-04-01 15:46:12 UTC
Good catch. Folder resources is indeed missing in svn repository. I didn't recognize this, as I just took a local copy
of my work space. Your should add "resources" manually.
BTW: Doesn't "Run make\src\build.tools.charsetmapping.GenerateCharsetData.java" work without "Build" from classes in
userdir cache, as it would create this folder?

If this doesn't help, I will zip you a copy of my workspace. Then you too also would see the diff between repo and local
contents of nbproject.

> 2) Run single test was renamed, ...
I know, thanks anyway.
Comment 9 ulfzibis 2009-04-01 23:27:19 UTC
Now you can checkout revision 696. (I have corrected nbproject/config/GenerateCharsetsData.properties)

To run from NetBeans 6.5, 2nd JDK must be installed (here: JDK 6u03).
Enable CoS and first Run-Single make\src\build.tools.charsetmapping.GenerateCharsetData.java from configuration
"GenerateCharsetData", then Build again from "default" configuration, to move the generated files to "build" and "dist".
After you can run the test classes, e.g. CharsetsTest.java.

Then install NB 6.7 M2 with importing settings from 6.5.
Open project, and try to run-single java.nio.cs.CharsetsTest.

If I right-click->Goto Source on unknown item (here ExtendedCharsets) from test/sun.nio.cs.LagacyCharset, I was leaded
to wrong location of another version of this java file.

> 2) Run single test was renamed, ...
Please note Issue 155537.
Comment 10 ulfzibis 2009-04-03 21:51:45 UTC
I can reproduce this issue with 6.7M3. :-(
Comment 11 Jiri Kovalsky 2009-04-09 14:43:53 UTC
Ulf addressed the comments hence removing INCOMPLETE keyword and raising priority to P2 because this is a fundamental
problem.
Comment 12 Dusan Balek 2009-04-10 10:40:05 UTC
I'll try to look at it.
Comment 13 ulfzibis 2009-04-15 12:13:41 UTC
Any news, progress ?
I'm heavily waiting to evaluate 6.7 by this project. It's the main I'm currently working on.
Comment 14 Dusan Balek 2009-04-15 15:07:08 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/91a948675403
changeset 1bdd2229f405 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=1bdd2229f405
Comment 15 Quality Engineering 2009-04-16 19:24:27 UTC
Integrated into 'main-golden', will be available in build *200904161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/91a948675403
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #161599: Project doesn't run anymore - fixed. Sig files should be preferred over class files.
Comment 16 ulfzibis 2009-05-07 23:43:17 UTC
Runs fine if project is imported in NB 6.7 Beta, but uses 450 MB memory for first scan. In 6.5 it only needed ~80 MB.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo