Bug 161366 - NullPointerException at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.readWizard
NullPointerException at org.netbeans.modules.ide.ergonomics.newproject.Descri...
Status: RESOLVED DUPLICATE of bug 162092
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@performance
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 16:13 UTC by pribyl
Modified: 2009-06-21 13:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.15 KB, text/plain)
2009-03-27 16:13 UTC, pribyl
Details
stacktrace (1.41 KB, text/plain)
2009-04-06 10:58 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pribyl 2009-03-27 16:13:46 UTC
Build: NetBeans IDE Dev (Build 200903261933)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
pribyl: (Ergonomics ENABLED)
I started creating new PHP project -> PHP plugin was being activated
I pressed  " < Back " and choosed to create new Ruby project. So another process activation begun, while the previous one was still running.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.readWizard(DescriptionStep.java:249)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.waitForDelegateWizard(DescriptionStep.java:235)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.access$200(DescriptionStep.java:79)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1$1.call(DescriptionStep.java:174)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1$1.call(DescriptionStep.java:170)
        at org.netbeans.modules.ide.ergonomics.fod.ConfigurationPanel$3$1.run(ConfigurationPanel.java:203)
Comment 1 pribyl 2009-03-27 16:13:59 UTC
Created attachment 78985 [details]
stacktrace
Comment 2 Marian Mirilovic 2009-04-06 10:58:49 UTC
Build: NetBeans IDE Dev (Build 200904051400)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
tried to verify issue 161542 and got NPE ...

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.readWizard(DescriptionStep.java:255)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.waitForDelegateWizard(DescriptionStep.java:224)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep.access$200(DescriptionStep.java:81)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1$1.call(DescriptionStep.java:165)
        at org.netbeans.modules.ide.ergonomics.newproject.DescriptionStep$1$1.call(DescriptionStep.java:161)
        at org.netbeans.modules.ide.ergonomics.fod.ConfigurationPanel$3$1.run(ConfigurationPanel.java:203)
Comment 3 Marian Mirilovic 2009-04-06 10:58:53 UTC
Created attachment 79516 [details]
stacktrace
Comment 4 Jaroslav Tulach 2009-04-09 12:36:45 UTC

*** This issue has been marked as a duplicate of 162092 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo