Bug 161311 - Deadlock after reformat
Deadlock after reformat
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
:
: 161290 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 21:59 UTC by David Strupl
Modified: 2009-04-01 09:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2009-03-26 21:59:14 UTC
I am filing this on behalf of dkonecny. Here are the thread dumps

http://www.netbeans.org/nonav/issues/showattachment.cgi/78865/threaddump.txt
http://www.netbeans.org/nonav/issues/showattachment.cgi/78869/threaddump.txt

David insisted that they are the same as #160323 which they are not IMHO. Vita, please evaluate, thanks.
Comment 1 David Strupl 2009-03-26 22:00:19 UTC
Oops, I forgot to put David on Cc and assign it directly to Vita.
Comment 2 David Konecny 2009-03-30 00:54:02 UTC
*** Issue 161290 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2009-03-30 12:04:18 UTC
http://hg.netbeans.org/jet-main/rev/4c80528f8504
Comment 4 Jiri Prox 2009-03-30 14:49:19 UTC
verified in trunk, please integrate the fix in release67_m3
Comment 5 Vitezslav Stejskal 2009-03-30 14:58:48 UTC
Transplanted to release_m3 clone as http://hg.netbeans.org/release67_m3/rev/ba534c65e5cf
Comment 6 Quality Engineering 2009-03-31 07:34:55 UTC
Integrated into 'main-golden', will be available in build *200903310200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4c80528f8504
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #161311 - locking the parsing infrastructure prior document locking
Comment 7 Jiri Prox 2009-04-01 09:47:02 UTC
verified in release_m3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo